Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Cisco 504G isn't seeing firmware past 7.5.2 - Can't upgrade to 7.6.1

Discussion in '3CX Phone System - General' started by jcockle2, Aug 24, 2017.

Thread Status:
Not open for further replies.
  1. jcockle2

    Joined:
    Aug 24, 2017
    Messages:
    1
    Likes Received:
    0
    I've got 20 or so Cisco 504G phones running on 3CX v15 Pro. When I try to perform a firmware upgrade through the main console there does not appear to be a newer version, despite 7.6.1 being fully supported and readily available according to other threads I've been reading.

    I've tried using the application to manually force an upgrade which failed. I've tried to force it by accessing a URL made up of the phone's IP and the path to the firmware - No luck there either, it says it will do it when the SPA is idle but it never does.

    Is there something I'm missing here? Only been in the game a short while but I feel like a firmware upgrade shouldn't be this hard! In case it wasn't apparent they are all on 7.5.2 at the moment.

    Screenshot of 7.5.2 appearing as the latest version - https://gyazo.com/975756913059440ba115bd227bad97ff
     
  2. cobaltit

    cobaltit Well-Known Member

    Joined:
    Mar 22, 2012
    Messages:
    1,609
    Likes Received:
    243
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. AlexDBarrett

    Joined:
    Jan 25, 2011
    Messages:
    71
    Likes Received:
    9
    The SPA504G is a legacy phone. You would be better off replacing them with a supported phone which will make management and upgrades far easier.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,086
    Likes Received:
    65
    The phones require certain firmware upgrades to be processed in order. You cannot go from your current version to the latest without first progressing through some of the versions in between. Unfortunately, I do not recall which versions are required and which can be skipped, but that is the issue.
     
  5. daneke

    Joined:
    May 8, 2017
    Messages:
    46
    Likes Received:
    4
    I got a Cisco phone working just for fun. You must setup a TFTP server, and follow all the directions on this page.
    Great phone quality, limited features on a foreign SIP system such as 3CX.
    https://www.3cx.com/Sip-Phones/Cisco-SPA/
     
  6. 3CXDude

    3CXDude New Member

    Joined:
    Oct 1, 2015
    Messages:
    110
    Likes Received:
    30
    Go to 7.5.2b first
     
    YiannisH_3CX likes this.
Thread Status:
Not open for further replies.