Cisco 7940 connecting remotely to 3CX server

Discussion in '3CX Phone System - General' started by miqna, Nov 9, 2009.

Thread Status:
Not open for further replies.
  1. miqna

    Joined:
    Mar 4, 2008
    Messages:
    5
    Likes Received:
    0
    Hi All, we have a 3CX server at loaction A. The phones at location A are all Cisco 7940/60 and access the 3CX server on the local network - everything works fine. We also have laptop computers with the 3CX soft phone, and these can connect to the 3CX server at location A from anywhere they are connected to the internet, so all the needed ports in the router at location A are open and directing to the 3CX server that is there.

    Theoretically, we should be able to take a Cisco 7940 phone to location B and connect it to the internet there, then, provided the SIP proxy host is configured to the public IP of location A, the Cisco 7940 should work just like a laptop with the soft phone, and connect into the system from location B.

    It doesn't work though. The phone has of course been tested at location A with the local settings and works just fine. At location B it doesn't connect. Location B router has ports open same as at location A, and the phone's internal IP is set to DMZ and the ports 5060, 42000-42019, 4300 are directing to it.

    Any suggestions?
     
  2. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,210
    Likes Received:
    85
    STUN im Phone eingeschaltet?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. KerryG

    KerryG Active Member

    Joined:
    Jun 19, 2009
    Messages:
    960
    Likes Received:
    0
    Those phones are seriously difficult to get to work as remote phones since the SIP stack in those phones is a very very poor implementation. You might have better luck using the 3CX SIp Proxy but really, they are probably the worst phones to try to get to work remotely.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Discovery Technology

    Joined:
    Apr 19, 2008
    Messages:
    278
    Likes Received:
    0
    Hi Miqna,

    Maybe this might be a bit more helpful.

    You have two options, and we have had the 7940 handsets working in either configuration.

    You could establish an IPSEC tunnel between your two sites and continue to use the same settings on the phone, or change the NAT settings in the phone config file (SIPDefault.cnf in this case) to reflect the fact that your handset is now sitting behind a NAT firewall as follows:

    Set nat_enable: to 1(0 -disable; 1- enable), nat_received_processing: to 1(0-disable; 1-enable) and to show the NAT IP address.

    Example (where 210.0.10.1 is your public IP):

    nat_enable: 1
    nat_address: 210.0.10.1
    nat_received_processing: 1

    It would be easier to achieve this with a local TFTP server at the remote location so you can distinguish between config file versions at the main office and at the remote office.

    Hope this helps.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.