Cisco 7940 Status Error: W310 2 Error(s) parsing: SIPDefault

Discussion in '3CX Phone System - General' started by noobie2, Mar 7, 2008.

Thread Status:
Not open for further replies.
  1. noobie2

    Joined:
    Feb 29, 2008
    Messages:
    7
    Likes Received:
    0
    Hi

    My Cisco 7940 phone registers and works with 3cx but I am getting this error on the phone:

    Here is my SIPDefault.cnf File:
    Code:
    # Image Version
    image_version: "P0S3-08-2-00"
    
    # Proxy Server
    proxy1_address: "192.168.1.115"
    
    # Proxy Server Port (default - 5060)
    proxy1_port:"5060"
    
    # Emergency Proxy info
    proxy_emergency: "192.168.1.115"
    proxy_emergency_port: "5060"
    
    # Backup Proxy info
    proxy_backup: "192.168.1.115"
    proxy_backup_port: "5060"
    
    # Outbound Proxy info
    outbound_proxy: "192.168.1.115"
    outbound_proxy_port: "5060"
    
    # NAT/Firewall Traversal
    nat_enable: "0"
    nat_address: ""
    voip_control_port: "5061"
    start_media_port: "16384"
    end_media_port:  "32766"
    nat_received_processing: "0"
    
    # Proxy Registration (0-disable (default), 1-enable)
    proxy_register: "1"
    
    # Phone Registration Expiration [1-3932100 sec] (Default - 3600)
    timer_register_expires: "3600"
    
    # Codec for media stream (g711ulaw (default), g711alaw, g729)
    preferred_codec: "none"
    
    # TOS bits in media stream [0-5] (Default - 5)
    tos_media: "5"
    
    # Enable VAD (0-disable (default), 1-enable)
    enable_vad: "1"
    
    # Allow for the bridge on a 3way call to join remaining parties upon hangup
    cnf_join_enable: "1"     ; 0-Disabled, 1-Enabled (default)
    
    # Allow Transfer to be completed while target phone is still ringing
    semi_attended_transfer: "1"   ; 0-Disabled, 1-Enabled (default)
    
    # Telnet Level (enable or disable the ability to telnet into this phone
    telnet_level: "2"      ; 0-Disabled (default), 1-Enabled, 2-Privileged
     
    # Inband DTMF Settings (0-disable, 1-enable (default))
    dtmf_inband: "1"
    
    # Out of band DTMF Settings (none-disable, avt-avt enable (default), avt_always - always avt )
    dtmf_outofband: "avt"
    
    # DTMF dB Level Settings (1-6dB down, 2-3db down, 3-nominal (default), 4-3db up, 5-6dB up)
    dtmf_db_level: "3"
    
    # SIP Timers
    timer_t1: "500"                   ; Default 500 msec
    timer_t2: "4000"                  ; Default 4 sec
    sip_retx: "10"                     ; Default 11
    sip_invite_retx: "6"               ; Default 7
    timer_invite_expires: "180"        ; Default 180 sec
    
    # Setting for Message speeddial to UOne box
    messages_uri: "999"
    
    # TFTP Phone Specific Configuration File Directory
    tftp_cfg_dir: "./"
    
    # Time Server
    sntp_mode: "unicast"
    sntp_server: "202.135.38.18"
    time_zone: "AEST"
    dst_offset: "1"
    dst_start_month: "April"
    dst_start_day: ""
    dst_start_day_of_week: "Sun"
    dst_start_week_of_month: "1"
    dst_start_time: "02"
    dst_stop_month: "Oct"
    dst_stop_day: ""
    dst_stop_day_of_week: "Sunday"
    dst_stop_week_of_month: "8"
    dst_stop_time: "2"
    dst_auto_adjust: "0"
    
    # Do Not Disturb Control (0-off, 1-on, 2-off with no user control, 3-on with no user control)
    dnd_control: "0"                  ; Default 0 (Do Not Disturb feature is off)
    
    # Caller ID Blocking (0-disabled, 1-enabled, 2-disabled no user control, 3-enabled no user control)
    callerid_blocking: "0"            ; Default 0 (Disable sending all calls as anonymous)
    
    # Anonymous Call Blocking (0-disbaled, 1-enabled, 2-disabled no user control, 3-enabled no user control)
    anonymous_call_block: "0"         ; Default 0 (Disable blocking of anonymous calls)
    
    # Call Waiting (0-disabled, 1-enabled, 2-disabled with no user control, 3-enabled with no user control)
    call_waiting: "1"                 ; Default 1 (Call Waiting enabled)
    
    # DTMF AVT Payload (Dynamic payload range for AVT tones - 96-127)
    dtmf_avt_payload: "101"           ; Default 100
    
    # XML file that specifies the dialplan desired
    dial_template: "dialplan"
    
    # Network Media Type (auto, full100, full10, half100, half10)
    network_media_type: "auto"
    
    #Autocompletion During Dial (0-off, 1-on [default])
    autocomplete: "1"
    
    #Time Format (0-12hr, 1-24hr [default])
    time_format_24hr: "1"
    
    # URL for external Phone Services
    services_url: "http://voipdir.naviston.com/"
    
    # URL for external Directory location
    directory_url: "http://voipdir.naviston.com/directory.xml"
    
    # URL for branding logo
    logo_url: "http://voipdir.naviston.com/asterisk-tux.bmp"
    
    # Remote Party ID
    remote_party_id: 1              ; 0-Disabled (default), 1-Enabled
    
    # Dialtone Stutter for MWI 
    stutter_msg_waiting: 1 		  ; 0-Disabled (default), 1-Enabled
    
    Any Ideas on what is wrong?

    Thanks

    Mark

    PS. Be kind, i'm a noobie2 :p
     
  2. ITWorks

    ITWorks New Member

    Joined:
    Apr 7, 2007
    Messages:
    121
    Likes Received:
    0
    Hmm might be this line:
    Seriously. Connect to the phone with a web browser and check the most recent log and you should see a parse error and the associated line number in your SIPDefault.cfg file.

    Mark
     
  3. noobie2

    Joined:
    Feb 29, 2008
    Messages:
    7
    Likes Received:
    0
    :lol:
    I Know! The .bmp is a little cheeky! but its the first cisco formatted pic i could find, just to test pulling a .bmp from an ip address.
    it may be a silly question but how do i log into the phone with a web browser? The phone ip is 192.168.1.104, but when i type that into IE7 i get nothing?
    What am i doing wrong?

    By the way, through trial and error i am down to 1 error now, changing the sntp_timeserver ip address seemed to help.

    Thx

    Mark

    PS be kind, i'm a noobie2 :p

    UPDATE: Here is the link to the cisco site to help with the time settings...
    http://www.cisco.com/univercd/cc/td/doc/product/voice/c_ipphon/mgcphone/refgd/mgcpconf.htm#25955

    I changed the time code to the following:
    Code:
    # Time Server
    sntp_mode: "unicast"
    sntp_server: "18.26.4.105"
    time_zone: "EST"
    dst_offset: "+hour"
    dst_start_month: "4"
    dst_start_day: "0"
    dst_start_day_of_week: "1"
    dst_start_week_of_month: "1"
    dst_start_time: "02:00"
    dst_stop_month: "10"
    dst_stop_day: "0"
    dst_stop_day_of_week: "1"
    dst_stop_week_of_month: "8"
    dst_stop_time: "02:00"
    dst_auto_adjust: "1"
    
     
  4. ITWorks

    ITWorks New Member

    Joined:
    Apr 7, 2007
    Messages:
    121
    Likes Received:
    0
    I was too quick to respond. I was thinking 7941's, which is what we use and has the web server built in.
    Mark
     
  5. noobie2

    Joined:
    Feb 29, 2008
    Messages:
    7
    Likes Received:
    0
    Hi All,

    By trial and error, I tracked down the remaining issue. it was in this line of code:
    Code:
    # TOS bits in media stream [0-5] (Default - 5)
    tos_media: "5"
    
    so I changed it to ...
    Code:
    # TOS bits in media stream [0-5] (Default - 5)
    # tos_media: "5"
    
    ... just commenting out the tos-media directive.

    Any thoughts on why this might cause a problem?

    Thx

    Mark
     
Thread Status:
Not open for further replies.