Cisco 7940 Time & Date

Discussion in '3CX Phone System - General' started by LyonAdmiral, Aug 11, 2015.

Thread Status:
Not open for further replies.
  1. LyonAdmiral

    Joined:
    Aug 10, 2015
    Messages:
    50
    Likes Received:
    1
    One of the things I discovered shortly after converting to 3CX was that 7940/60 phones work better with the provided SIP firmware than the 7941/61 phones at the very least in the sense that they display the correct date and time. I discovered that upon provisioning our first 7960 phone, I was pleased and impressed.

    However, I'm finding that as I have been provisioning other phones both 7940's and 60's that the time and date is not showing up on the home screen at all and the "E102 MISC Error: No time server" is showing up in the Status Messages log in the phone.

    Is the solution to this problem something as simple as restarting a service or the entire VM that 3CX is sitting in?

    Thanks,
    Daniel
     
  2. pj3cx

    pj3cx Active Member

    Joined:
    Aug 1, 2013
    Messages:
    645
    Likes Received:
    1
    Hi there,
    Regarding the ciscos 7941/7961 not getting the right time please try the following :
    - go in Settings / Provisioning Templates, select cisco 7941
    - search for <ntp>, in the below <name> tag is a hardcoded ntp server ip please replace with %%param::time_ntp_server%%
    - apply, overwrite existing file
    - go in Extensions page, edit your extension, go in Phones provisioning tab
    - add a BLF, apply. remove a BLF and apply.
    - reprovision phone using DHCP 66 + TFTP as described in our provisioning guide.

    The ntp server used for the phone time synch will now be the global one specified under Settings / Phone Provisioning tab, you must ensure the phone can reach the said host/ip on port 123 udp.
    Let me know if issues persists
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.