Cisco 7975 cannot register to 3CX

Discussion in '3CX Phone System - General' started by Trixxie, Jul 23, 2010.

Thread Status:
Not open for further replies.
  1. Trixxie

    Joined:
    Jul 23, 2010
    Messages:
    2
    Likes Received:
    0
    Hi,
    I am struggeling for a day now and I cannot get it oke.

    I have a 3cx and a Cisco 7975 with the following config file:

    <device>
    <fullConfig>true</fullConfig>
    <deviceProtocol>SIP</deviceProtocol>
    <sshUserId>admin</sshUserId>
    <sshPassword>cisco</sshPassword>
    <devicePool>
    <dateTimeSetting>
    <dateTemplate>D.M.Y</dateTemplate>
    <timeZone>W. Europe Standard/Daylight Time</timeZone>
    <ntps>
    <ntp>
    <name>NTP SERVER</name>
    <ntpMode>Unicast</ntpMode>
    </ntp>
    </ntps>
    </dateTimeSetting>
    <callManagerGroup>
    <tftpDefault>true</tftpDefault>
    <members>
    <member priority="0">
    <callManager>
    <ports>
    <ethernetPhonePort>2000</ethernetPhonePort>
    <sipPort>5060</sipPort>
    </ports>
    <processNodeName>IP ADRES 3CX</processNodeName>
    </callManager>
    </member>
    </members>
    </callManagerGroup>
    </devicePool>
    <commonProfile>
    <phonePassword></phonePassword>
    <backgroundImageAccess>true</backgroundImageAccess>
    <callLogBlfEnabled>0</callLogBlfEnabled>
    </commonProfile>
    <loadInformation>SIP75.9-0-3S</loadInformation>
    <vendorConfig>
    <disableSpeaker>false</disableSpeaker>
    <disableSpeakerAndHeadset>false</disableSpeakerAndHeadset>
    <pcPort>0</pcPort>
    <settingsAccess>1</settingsAccess>
    <garp>0</garp>
    <voiceVlanAccess>0</voiceVlanAccess>
    <videoCapability>0</videoCapability>
    <autoSelectLineEnable>0</autoSelectLineEnable>
    <daysDisplayNotActive>1,7</daysDisplayNotActive>
    <displayOnTime>10:30</displayOnTime>
    <displayOnDuration>06:05</displayOnDuration>
    <displayIdleTimeout>00:05</displayIdleTimeout>
    <webAccess>1</webAccess>
    <spanToPCPort>1</spanToPCPort>
    <loggingDisplay>1</loggingDisplay>
    <loadServer></loadServer>
    </vendorConfig>
    <userLocale>
    <name>English_United_States</name>
    <uid>1</uid>
    <langCode>en_US</langCode>
    <version>1.0.0.0-1</version>
    <winCharSet>iso-8859-1</winCharSet>
    </userLocale>
    <networkLocale>United_States</networkLocale>
    <networkLocaleInfo>
    <name>United_States</name>
    <uid>64</uid>
    <version>1.0.0.0-1</version>
    </networkLocaleInfo>
    <capfAuthMode>0</capfAuthMode>
    <capfList>
    <capf>
    <phonePort>3804</phonePort>
    </capf>
    </capfList>
    <certHash></certHash>
    <encrConfig>false</encrConfig>
    <sipProfile>
    <sipProxies>
    <backupProxy>IP ADRES 3CX</backupProxy>
    <backupProxyPort>5060</backupProxyPort>
    <emergencyProxy></emergencyProxy>
    <emergencyProxyPort></emergencyProxyPort>
    <outboundProxy>IP ADRES 3CX</outboundProxy>
    <outboundProxyPort></outboundProxyPort>
    <registerWithProxy>true</registerWithProxy>
    </sipProxies>
    <sipCallFeatures>
    <cnfJoinEnabled>true</cnfJoinEnabled>
    <callForwardURI>x--serviceuri-cfwdall</callForwardURI>
    <callPickupURI>x-cisco-serviceuri-pickup</callPickupURI>
    <callPickupListURI>x-cisco-serviceuri-opickup</callPickupListURI>
    <callPickupGroupURI>x-cisco-serviceuri-gpickup</callPickupGroupURI>
    <meetMeServiceURI>x-cisco-serviceuri-meetme</meetMeServiceURI>
    <abbreviatedDialURI>x-cisco-serviceuri-abbrdial</abbreviatedDialURI>
    <rfc2543Hold>true</rfc2543Hold>
    <callHoldRingback>2</callHoldRingback>
    <localCfwdEnable>true</localCfwdEnable>
    <semiAttendedTransfer>true</semiAttendedTransfer>
    <anonymousCallBlock>2</anonymousCallBlock>
    <callerIdBlocking>0</callerIdBlocking>
    <dndControl>0</dndControl>
    <remoteCcEnable>true</remoteCcEnable>
    </sipCallFeatures>
    <sipStack>
    <sipInviteRetx>6</sipInviteRetx>
    <sipRetx>10</sipRetx>
    <timerInviteExpires>180</timerInviteExpires>
    <timerRegisterExpires>3600</timerRegisterExpires>
    <timerRegisterDelta>5</timerRegisterDelta>
    <timerKeepAliveExpires>120</timerKeepAliveExpires>
    <timerSubscribeExpires>120</timerSubscribeExpires>
    <timerSubscribeDelta>5</timerSubscribeDelta>
    <timerT1>500</timerT1>
    <timerT2>4000</timerT2>
    <maxRedirects>70</maxRedirects>
    <remotePartyID>false</remotePartyID>
    <userInfo>None</userInfo>
    </sipStack>
    <autoAnswerTimer>1</autoAnswerTimer>
    <autoAnswerAltBehavior>false</autoAnswerAltBehavior>
    <autoAnswerOverride>true</autoAnswerOverride>
    <transferOnhookEnabled>true</transferOnhookEnabled>
    <enableVad>false</enableVad>
    <preferredCodec>g711u</preferredCodec>
    <dtmfAvtPayload>101</dtmfAvtPayload>
    <dtmfDbLevel>3</dtmfDbLevel>
    <dtmfOutofBand>avt</dtmfOutofBand>
    <alwaysUsePrimeLine>false</alwaysUsePrimeLine>
    <alwaysUsePrimeLineVoiceMail>false</alwaysUsePrimeLineVoiceMail>
    <kpml>3</kpml>
    <stutterMsgWaiting>1</stutterMsgWaiting>
    <callStats>false</callStats>
    <silentPeriodBetweenCallWaitingBursts>10</silentPeriodBetweenCallWaitingBursts>
    <disableLocalSpeedDialConfig>false</disableLocalSpeedDialConfig>
    <startMediaPort>16384</startMediaPort>
    <stopMediaPort>32766</stopMediaPort>
    <voipControlPort>5060</voipControlPort>
    <dscpForAudio>184</dscpForAudio>
    <ringSettingBusyStationPolicy>0</ringSettingBusyStationPolicy>
    <phoneLabel>PHONE LABEL</phoneLabel>
    <sipLines>
    <line button="1">
    <featureID>9</featureID>
    <featureLabel>102</featureLabel>
    <name>102</name>
    <displayName>102</displayName>
    <contact>102</contact>
    <proxy>IP ADRES 3CX</proxy>
    <port>5060</port>
    <autoAnswer>
    <autoAnswerEnabled>2</autoAnswerEnabled>
    </autoAnswer>
    <callWaiting>3</callWaiting>
    <authName>102</authName>
    <authPassword>102</authPassword>
    <sharedLine>false</sharedLine>
    <messageWaitingLampPolicy>1</messageWaitingLampPolicy>
    <messagesNumber>999</messagesNumber>
    <ringSettingIdle>4</ringSettingIdle>
    <ringSettingActive>5</ringSettingActive>
    <forwardCallInfoDisplay>
    <callerName>true</callerName>
    <callerNumber>false</callerNumber>
    <redirectedNumber>false</redirectedNumber>
    <dialedNumber>true</dialedNumber>
    </forwardCallInfoDisplay>
    </line>

    </sipLines>
    </sipProfile>
    </device>

    I hope that somebody has the answer for me :)

    Greetings, Trixxie
     
  2. LeonidasG

    LeonidasG Support Team
    Staff Member 3CX Support

    Joined:
    Nov 19, 2008
    Messages:
    1,475
    Likes Received:
    94
    Hi,

    Does the phone even startup correctly?
    Does it load the configuration correctly and do you even see the phone trying to register?

    Also give this guide made by KerryG a go, it will save you a week of trying to configure that damn phone :p
    http://www.voipstore.com/configuring-cisco-7975-ip-phones-for-sip/
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Trixxie

    Joined:
    Jul 23, 2010
    Messages:
    2
    Likes Received:
    0
    Hi,

    The phone startup is good. First I see the cisco startup logo and then a few seconds later it picks up the time and background picture. After that you only see down in the left "Registering" but nothing happens.

    The website wich you ment here above is the sample what I used. I only changed the things what that guy tolds us.

    Could it be that my firmware (9.0.3) is to high/new for 3CX ?

    Thank for your time.
     
  4. KerryG

    KerryG Active Member

    Joined:
    Jun 19, 2009
    Messages:
    960
    Likes Received:
    0
    The ENTIRE trick to getting those phones to work is getting the correct firmware. The most current versions DO NOT WORK with third party PBX systems.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.