Cisco 79xx series problems

Discussion in 'Windows' started by Sn0wbl1nd, Jun 11, 2012.

Thread Status:
Not open for further replies.
  1. Sn0wbl1nd

    Joined:
    Jun 11, 2012
    Messages:
    2
    Likes Received:
    0
    anyone have the problem where the SETTINGS button on the 7940 7960 series CISCO phones not responding?

    i have factory default the phones by holding # on startup then pressing 123456789*0#.. also i can restart the phones by pressing * 6 SETTINGS buttons but i cannot manualy configure the phone. once it starts up it just cycles till it errors out on TFTP server not found .... i have plenty of other 7940 7960 phones working atm so i know its not my setup or config .. its on the phone itself.

    TIA for any and all responces
     
  2. alizian

    Joined:
    Apr 19, 2012
    Messages:
    3
    Likes Received:
    0
    Sounds to me like the phone itself. I had a similar issue a while back and I reflashed the firmware to POS3-08-9-00 (it was on 3-08-2-00) and it fixed it, so I'd try that before sending it to the bin.

    I'm struggling to get my 7940 phones to work with 3CX. They work fine with AsteriskNow and I've taken a couple off and connected them to the 3CX network, and I can get a dial tone OK. I can't seem to get them to recognise the files in the TFTP root folder (using SolarWinds TFTP). Any chance you could get me a working template for eachSIP file that's needed?

    TIA

    Dermot
     
  3. mixig

    mixig Active Member

    Joined:
    Dec 13, 2011
    Messages:
    523
    Likes Received:
    12
    7940 with 3cx, everything is working...

    useful links:
    http://gregsowell.com/?p=1497
    http://www.youtube.com/watch?v=690-4S2CS5U

    firmware: P0S3-8-12-00

    tftp: tftpd32
     
  4. Sn0wbl1nd

    Joined:
    Jun 11, 2012
    Messages:
    2
    Likes Received:
    0
    Thanks for the reply alizian,

    if i cant get it to communicate to my TFTP server i dont think i can flash the phone .. it will not register at all so its like its not communicating with anything atm :S

    i would try using a diff TFTP client http://tftpd32.jounin.net/ is what we use also make sure you have the right options enabled in the DHCP server

    IP Address (DHCP Option 50)

    Subnet Mask (DHCP Option 1)

    Default IP Gateway (DHCP Option 3)

    DNS Server Address (DHCP Option 6)

    TFTP Server (DHCP Option 66)

    Domain Name (DHCP Option 15)
     
Thread Status:
Not open for further replies.