Cisco phone problem remote site

Discussion in '3CX Phone System - General' started by digito30, Dec 3, 2014.

Thread Status:
Not open for further replies.
  1. digito30

    Joined:
    Sep 19, 2013
    Messages:
    1
    Likes Received:
    0
    hello,

    I explain the problem I am facing.

    I have several remote facility compared to my 3CX server I configured my Cisco phones in this way:

    "Think uncheck Allow external access in the extension properties
    For relevant extensions must also check "PBX delivers audio"

    Open port 5060 and RTP ports on the router

    then:

    Additional Configuration for Remote Extensions

    If you want to configure the phone as a Remote Extension, You Will need to Log assurer que la "Proxy" field is set to the Public IP Address of the PBX, and perform aussi The Following configuration adjustments':

    Go to the "Ext1" tab
    Go to the "NAT Settings" section
    Set the "NAT Mapping Enable" field to "yes"
    Set the "NAT Keep Alive Enable" field to "yes"

    Go to the "SIP" tab
    Go to the "NAT Support Parameters" section
    Set the "Handle VIA rport" field to "yes"
    Set the "Insert VIA rport" field to "yes"
    Set the "Enable STUN" field to "yes"
    Set the "STUN Server" field to "stun.3cx.com" - to allow the phone to discover icts external IP Address, and the Port mappings That Will Be Applied to the traffic sent and received by the phone
    Click the "Submit All Changes" button at the bottom of the page. Will your phone restart. "

    but I end up with a problem, such as when the standard receive an outside call and that the transfer was one of my remote phones at the end of the call after hanging up the remote phone freeze randomly or if it not freeze it simply can not make calls, when you want to make a call he gets "answerring" but does not ring and nothing happens ... having to restart the phone to work again, to transfer an external call and looping ...

    Do you have a solution to the problem please ??

    Thank you in advance
     
  2. nikosT_3cx

    3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    57
    Likes Received:
    0
    Hi,

    the method that you have used is not the supported one so please check the article on our website witch has a step by step guide on how to provision remote extensions : http://www.3cx.com/blog/docs/provisioning-a-remote-extension/

    Also as per manual by default, 3CX Phone System assumes that you have a static IP and therefore the STUN server option is switched off. If you have a dynamic IP, you have to enable the STUN server. Please note that use of a dynamic IP is only suited for testing 3CX Phone System. It is not recommended for a production system. Disable the STUN Server requests, specify your Static Public ip address, and on the Local SIP Domain as well ( Public ip address ) restart the services in order to apply the changes on the system and proceed with the appropriate guide.
     
  3. Matthewh

    Joined:
    Jun 3, 2014
    Messages:
    13
    Likes Received:
    0
    I have a similar issue with cisco phones, some but not all of my remote users are unable to pickup inbound calls, they can connect and register just fine and if they initiate the call it works perfectly, if however I call them I can hear them talking just fine but they dont get the audio from my end back to them.

    Any ideas welcomed?
     
  4. cobaltit

    cobaltit Active Member

    Joined:
    Mar 22, 2012
    Messages:
    733
    Likes Received:
    112
    @digito30

    I think nikost_3cx misread your post, as you don't indicate you have STUN server option turned on in 3CX. But he is correct in that you should provision the phones if possible but if not, here are the settings I would change:

    STUN Server should be: "ext.pbx.ip:5060" (if on v12)
    Not sure what you have NAT Keep Alive set to, but set it to "15"


    If you don't want to open the firewall for provisioning, you can always generate the config and then compare the settings.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.