Cisco SPA504G - 503 Service unavailable for incoming call

Discussion in '3CX Phone System - General' started by michaelsalzburg, Sep 4, 2012.

Thread Status:
Not open for further replies.
  1. michaelsalzburg

    Joined:
    Sep 4, 2012
    Messages:
    3
    Likes Received:
    0
    Hi,

    we have a 3CX pbx V10 and are using Cisco SPA504G with firmware 7.5.2b.

    Since a few weeks we have troubles with phones that are connected via the 3CX tunnel proxy (proxy manager). After starting/rebooting the phone everything works fine. But after some time (sometimes 10 minutes, sometimes 24 hours) incoming calls don't work any more. In the 3CX log the error "503 Service unavailable" is listed. Rebooting the phone solves the problem temporarly, but there should be a better solution.
    Does anyone have an idea how to solve it?

    3CX-Log:
    3CX-Tunnel-Log:
     
  2. 3CXfoxhallsolutions

    3CXfoxhallsolutions New Member

    Joined:
    Sep 8, 2012
    Messages:
    211
    Likes Received:
    0
    Re: Cisco SPA504G - 503 Service unavailable for incoming cal

    Hi Michael
    You refer to phone and phones ... So I'm not sure if this is a one- or many-phone problem??

    If you have multiple SPA504g phones at the remote site all working through the same Proxy tunnel - it might help if you stagger the SIP ports that each SPA504G extension is using ... i.e. each phone will have extension 1 working on 5060 by default, so all phones will be working the same SIP port.

    Try putting ext.1 of the first phone on 5061, ext.1 of the second phone on 5062, ext.1 of the third phone on 5063 etc. so that all working extensions have different SIP port settings (same for extensions 2, 3, or 4 if you have multiple extensions on the phones). You can find this 'SIP Port:' setting on each extension setting page of the 504G.

    best regards
    Graham Hill
    Foxhall Solutions
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.