Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Client on Citrix not connecting

Discussion in 'Windows' started by DolbySR, Oct 24, 2017.

Thread Status:
Not open for further replies.
  1. DolbySR

    Joined:
    Jul 13, 2016
    Messages:
    9
    Likes Received:
    0
    Hi there

    I have a strange problem at a customer's place. He's working on a Citrix server which is in our Datacenter, basically "next to" his 3CX Server, which is in a different subnet. In between, there is a firewall, where I have opened the required ports for 3CX:
    5060, 5090, 80, 443, 5000, 5001

    From my computer at work, the 3CX client can connect to the server. From the Citrix server, it simply won't connect. Here's what the log says about it:

    [24.10.2017 09:26:48.143][1] 3CXTunnel: Stopping tunnel service, waiting indefinitely
    [24.10.2017 09:26:48.143][1] 3CXTunnel: Tunnel service destroyed
    [24.10.2017 09:26:48.143][1] Biz FreeSIPResources finished
    [24.10.2017 09:26:48.290][1] LoginCallback() starts
    [24.10.2017 09:26:48.291][1] Setting app channel to null, was null
    [24.10.2017 09:26:48.291][1] UnsubscribeEventsFromMyPhoneAndCTI()
    [24.10.2017 09:26:48.293][1] Setting tmp channel to null, was [ 1789605 at https://SERVERADDRESS:5001/myphone/MPWebService.asmx ]
    [24.10.2017 09:26:48.293][1] UnsubscribeEventsFromMyPhoneAndCTI() finished
    [24.10.2017 09:26:48.293][1] Error occurred when login to my phone
    [24.10.2017 09:26:48.293][1] System.MissingMethodException: Methode nicht gefunden: "Void MyPhoneClientChannelNet.Interfaces.IClientChannel.set_ServerVersion(System.String)".
    bei _3CXWin8Phone.MainWindow.SetMyPhoneChannel(LoginInfo login)
    bei _3CXWin8Phone.MainWindow.LoginCallback(Object sender, LoginInfoEventArgs args)

    [24.10.2017 09:26:48.293][1] LoginCallback() ended
    [24.10.2017 09:26:48.293][1] LoginCallback() starts
    [24.10.2017 09:26:48.293][1] LoginCallback() channel mismatch: current tmp channel = null, app channel = null, got channel [ 1789605 at https://SERVERADDRESS:5001/myphone/MPWebService.asmx ]
    [24.10.2017 09:26:48.294][1] Connection to myphone server [ 1789605 at https://SERVERADDRESS:5001/myphone/MPWebService.asmx ] got established successfully
    [24.10.2017 09:26:48.294][1] Closed myphone reconnection message window
    [24.10.2017 09:26:48.294][1] Error occurred during myphone connected event
    [24.10.2017 09:26:48.294][1] System.Exception: Channel seems to be already disconnected
    bei _3CXWin8Phone.MainWindow.channel_Connected(Object sender, EventArgs e)

    [24.10.2017 09:26:48.294][1] channel_ServerEvent() channel mismatch: current tmp channel = null, app channel = null, got channel [ 1789605 at https://SERVERADDRESS:5001/myphone/MPWebService.asmx ]
    [24.10.2017 09:26:48.294][1] channel_ServerEvent() channel mismatch: current tmp channel = null, app channel = null, got channel [ 1789605 at https://SERVERADDRESS:5001/myphone/MPWebService.asmx ]
    [24.10.2017 09:26:48.294][1] channel_ServerEvent() channel mismatch: current tmp channel = null, app channel = null, got channel [ 1789605 at https://SERVERADDRESS:5001/myphone/MPWebService.asmx ]
    [24.10.2017 09:26:48.294][1] channel_ServerEvent() channel mismatch: current tmp channel = null, app channel = null, got channel [ 1789605 at https://SERVERADDRESS:5001/myphone/MPWebService.asmx ]
    [24.10.2017 09:26:48.294][1] channel_ServerEvent() channel mismatch: current tmp channel = null, app channel = null, got channel [ 1789605 at https://SERVERADDRESS:5001/myphone/MPWebService.asmx ]
    [24.10.2017 09:26:48.294][1] channel_ServerEvent() channel mismatch: current tmp channel = null, app channel = null, got channel [ 1789605 at https://SERVERADDRESS:5001/myphone/MPWebService.asmx ]



    Any ideas? I don't get it.

    Regards,
    Patrick
     
Thread Status:
Not open for further replies.