Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Cloud Server 12 + Windows Phone 12

Discussion in '3CX Phone System - General' started by slwtx1983, May 16, 2014.

Thread Status:
Not open for further replies.
  1. slwtx1983

    Joined:
    May 16, 2014
    Messages:
    10
    Likes Received:
    0
    I was upgrading from a single 3cx Phone System 12 to a Cloud Server 12. Everything was working perfectly before the upgrade to Cloud Server 12, and now my Remote users will not connect. It connects to make phone calls, but I get an error about "unable to connect to web api" and it warns that it won't grab presence or contacts.

    I am not sure what the heck is going on here, as I have been working on this issue for about 5 hours. I followed the manual for Cloud Server 12 and made sure the ports are all setup on the router. I have rebooted everything many times. I ran WireShark on the 3cxPhone 12 machine and all I can see from it is the error pasted below. I can browse to the site directly. I think it is trying to NOT use SSL. However, I don't know how to change that.

    POST /visiondesign/MyPhone/MPWebService.asmx HTTP/1.1
    Content-Type: text/xml; charset=utf-8
    SOAPAction: "http://3cx.com/webservices/Call"
    Host: **REDACTED**
    Content-Length: 301
    Expect: 100-continue
    Accept-Encoding: gzip, deflate

    HTTP/1.1 403 Forbidden
    Content-Type: text/html
    Server: Microsoft-IIS/7.5
    X-Powered-By: ASP.NET
    Date: Fri, 16 May 2014 01:34:11 GMT
    Content-Length: 1233
     
  2. roland_3CX

    roland_3CX Support Team

    Joined:
    Mar 28, 2014
    Messages:
    131
    Likes Received:
    7
    Hi Slwtx


    Please reprovision your phone and kindly note that the cloud server uses different ports depending on the tenants. you may consult the cloud server manual provided below. If the issue persist after the phone provisioning, please contact our support team.

    http://www.3cx.com/manual/3CXCloudServerManual12.pdf
     
  3. slwtx1983

    Joined:
    May 16, 2014
    Messages:
    10
    Likes Received:
    0
    I reprovisioned all remote devices by sending a new Welcome email after manually creating all accounts. I also followed the manual, and setup all the new ports. The CTI connects up just fine, but I get the error about the Web API when trying to use the softphone.

    Alternatively, the Android and iPhone softphones work just fine. It is just the Windows Phone v12 in Softphone mode that gives me this error. When running Wireshark and analyzing the TCP Stream, it appears it gives me that HTTP/1.1 403 Forbidden, as shown in my first thread.

    I also just logged into my server and opened up the Windows Firewall to verify settings. I noticed that it opened 54000-65000 for the Media Server, and not the recommended 55000-65000 that it says in the manual. I also noticed that for my first client in Cloud Server it opened up port 5000, but for my second client it opened up 6001. Do I need 5000,6000,7000, etc.. open for each client? Also, do I need 5001,6001,7001, etc.. open for each client? Is there a feature that may be missing in my first client? Please note, I have Windows Firewall turned off, but 3cx configured it automatically, so I was able to verify settings. If the first client of mine did not setup the 5001 port, does that mean that I have to reconfigure them to access Secure Updates somehow?

    Also, why doesn't the Cloud Server manual mention ports 5000 and 5001? I found these ports during my extensive troubleshooting and looking into all the ports used by the older 3cx systems.
     
Thread Status:
Not open for further replies.