Codec Pass thru. Is it possible?

Discussion in '3CX Phone System - General' started by rferreirat, Sep 3, 2011.

Thread Status:
Not open for further replies.
  1. rferreirat

    Joined:
    Sep 3, 2011
    Messages:
    4
    Likes Received:
    0
    I recently installed 3XC PBX version 10 and have not been able to place calls using pass thru mode, or either other mode actually, but that is not relevant. I have unchecked PBX delivers audio on both, extension and SIP trunk, and still it does not work, the error message in the log shows "Unsupported Media Type" and Wireshark traces shows the codecs offered in the INVITE message to the SIP trunk are those listed in the Sip trunk config (GSM, g711) instead of those supported by the SPA (g729/g723/g711) , hence the call dies because the Sip trunk does not support GSM or g711. Hope someone can help me or give an idea how to make 3XC to offer codecs according to the caller extension capabilities ?
     
  2. willow

    willow Member

    Joined:
    Mar 1, 2011
    Messages:
    471
    Likes Received:
    0
    under the pstn gateway form, you need to set the proper codecs.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. rferreirat

    Joined:
    Sep 3, 2011
    Messages:
    4
    Likes Received:
    0
    I don't have anything configured under "PSTN Devices", only under "Extensions" and "Voip Providers" Call is originated from a extension (SPA-200) and is supposed to terminate on a SIP Voip Provider. Sorry for not clarifying that before.
     
  4. willow

    willow Member

    Joined:
    Mar 1, 2011
    Messages:
    471
    Likes Received:
    0
    make sure that to match what your sip provider is supporting. just because the sip trunk in 3cx is set you still need to makw sure that the provider supports it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. rferreirat

    Joined:
    Sep 3, 2011
    Messages:
    4
    Likes Received:
    0
    Thanks for your reply, the problem I have is basically my SIP provider only accept g729 and g723, and the PBX does not offer those options (at least the trial version) However the SPA200 can handle g729,g723 and g711. That is why I am trying to set pass-thru mode as the endpoints have matching codecs. Do you think that is possible ?
     
  6. willow

    willow Member

    Joined:
    Mar 1, 2011
    Messages:
    471
    Likes Received:
    0
    on SIP trunks, most of the time the PBX has to deliver audio as it is the one that is registered and has port 5060 forwarded to it. I do not think that you will be able to get this to work. I would recommend either using the free demo key with 2 SC license or purchase a license. If you need assistance please feel free to contact us if you are in the USA.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,825
    Likes Received:
    2
    How to get "Codec Pass thru" is described in http://www.3cx.com/blog/docs/media-server/
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. rferreirat

    Joined:
    Sep 3, 2011
    Messages:
    4
    Likes Received:
    0
    It does work, I had to select the option "Supports Re-invite" as well as unset "PBX Deliver Audio" on both the VOIP Provider and Extensions.

    Thanks for your Help.
     
Thread Status:
Not open for further replies.