Solved Codec Priority

Discussion in '3CX Phone System - General' started by complex1, Jan 19, 2018.

Thread Status:
Not open for further replies.
  1. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    752
    Likes Received:
    38
    Hi,

    3CX v15.5 is running on Debian 9 and installed on a local machine.
    Two phones (T48G and W56P) are attached to the same local network as the PBX is.
    Both phones are provisioned with the codec order: G722,PCMA,PCMU,G729.
    PBX delivers audio is off.

    What I understand is the codec priority is determined by the offeror, so when an extension calls another extension and there is not PBX delivers audio then the codec priority will be determined by the extension that initiates the call…, but this does not happen.
    The used codec at the destination is always PCMU while the offeror uses a other codec, e.g G722,G729,etc.

    Activity log is switched to Verbose mode and also here you can see the PBX offer only the PCMU codec when calling the extension.
    Switching PBX delivers audio on/off has no effect.

    Possible bug or did I miss I something?

    Please advise.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,368
    Likes Received:
    228
    Is it possible that another option, in the sets, such as DTMF method (Audio?), is forcing the sets to not use a low bit-rate Codec?
     
  3. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,442
    Likes Received:
    61
    I'm not sure, but you could also check if PBX has "Record all calls" enabled - as far as I know, this option also forces audio transcoding like "PBX delivers audio" does.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    complex1 likes this.
  4. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    752
    Likes Received:
    38
    @Vali_3CX,

    You're right. (I should have known what caused it (as 3CX partner))
    “Record all calls” was enabled and forces the audio transcoding.
    After disable this feature all work well.

    Thank you for the help.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.