Company Directory Sync Not working

Discussion in '3CX Phone System - General' started by mrteriyaki, Mar 21, 2016.

Thread Status:
Not open for further replies.
  1. mrteriyaki

    Joined:
    Mar 16, 2016
    Messages:
    2
    Likes Received:
    0
    Hi,
    I'm having trouble connecting the Company Phonebook to our MSSQL database.
    I have a Pro Server License (Without maintenance contract)

    The testing tool shows the correct data using settings:

    Connection string: DSN=GICI;UID=GICI; PWD=testpassword!@#
    Query: select companyname,phonenumber from view3CX where phonenumber like '%%number%'
    Assignment: firstname=0,phonenumber=1,company=0

    However when using the same settings with 3CX I get nothing, I can't find any error messages, nothing on the ODBC trace log.

    The server is running V14 SP3.
    I've also tried the preference over LDAP option both disabled and enabled.

    Can anyone advise what I'm doing wrong?
     
  2. pj3cx

    pj3cx Active Member

    Joined:
    Aug 1, 2013
    Messages:
    645
    Likes Received:
    1
    Hi there,
    Ensure that your DSN string has been input in 3CX without "DSN=" as this will be prepended automatically by the system.
    Also, make sure that the fields have been mapped starting from 0, for e.g Company: 0, Mobile: 1.
    Finally, note that a query for matching will be sent only when a call from an unknown number is answered.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.