Company Directory Sync

Discussion in '3CX Phone System - General' started by craigreilly, Sep 3, 2013.

Thread Status:
Not open for further replies.
  1. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,129
    Likes Received:
    207
    I followed the blog post about settings this up for my Exchange 2007 server. It is running Update Rollup 7. Do we need to be on a higher Rollup? 8,9,10,11 ?

    My OWA Link: https://serverFQDN/owa
    Public folder: AVC Associates

    I get an error:
    Code:
    Error while downloading contacts from Public Folders. Message: Exchange Server doesn’t support the requested version., StackTrace: at _3CXCompanyDirectoryService.Business.Clients.EWSPublicFolderClient.GetContactsFromPublicFolder(Int32 id, List`1 phoneNumberTypes, String restrictedCharacters, String PublicFolder, String ConvertPlusTo, List`1 Transl)
     at _3CXCompanyDirectoryService.SchedulerJob.GetNewPublicContacts(String PublicFolder), Source: 3CXCompanyDirectoryService.Business
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. AndreasP_3CX

    AndreasP_3CX New Member
    3CX Support

    Joined:
    Feb 15, 2013
    Messages:
    196
    Likes Received:
    2
    Hi Craig,

    As it shows the issue should be solved easily by going to :
    1. Management Console
    2. Settings>> Advanced
    3. Company Directory Sync >> and select Exchange 2007 from from the “Select MS Exchange Version” drop down menu, select Exchange Server 2007

    Please let me know if this has solved your issue or the problem still persists

    Regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,129
    Likes Received:
    207
    When I set my server to Exchange 2007 in the settings, the server log shows “ExchangeServerVersion: Exchange2010″

    When I set my server to Exchange 2010 in the settings, the server log shows “ExchangeServerVersion: Exchange2010_SP1″

    When I set my server to Exchange 2010 SP1 in the settings, the server log shows “ExchangeServerVersion: Exchange2010_SP2″

    When I set my server to Exchange 2013 in the settings, the server log shows “ExchangeServerVersion: Exchange2013″

    There doesn't appear to be a way to set 2007 even though I select it.

    This was an upgrade from RC1. A clean install of RC2 does not fix this.

    I finally found the config file in C:\ProgramData\3CX\Bin and set the Exchange bit to 0. It was set to a 1.
    According to the info in the config file, 1 should have been correct. But when I set to a 0, restarted services. The sync occurred.

    Problem now, each person has multiple entries -why not map to the correct field?
    And 2, the hyphen between Area Code and Prefix is stripped but not from the last 4 digits.

    ie:
    Craig Reilly [Business2] 480555-1212
    Craig Reilly [Mobile] 480555-1313
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,210
    Likes Received:
    85
    Hey,

    i have send you an e-mail regarding this.
    plz update post after the test build i gave you
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.