Config server is not connected

Discussion in 'CRM / Helpdesk / App Integration' started by leemul, Sep 21, 2016.

Thread Status:
Not open for further replies.
  1. leemul

    Joined:
    Aug 15, 2016
    Messages:
    5
    Likes Received:
    0
    Hi,

    I've created a web service which sits on the same dedicated server as the 3CX PBX.

    The webservice interacts with the 3CX API, and for about half an hour it works fine, making calls, checking call status, connections etc...

    However, all of a sudden it will start throwing errors with the following:

    Config server is not connected at TCX.Configuration.PhoneSystem.Connect() at TCX.Configuration.PhoneSystem.get_Root() at _3CXAPI.connectionTools.startSystemConnection(String configFile)

    Now, I've followed the API guide, and connected via the preferred v14 method (and legacy to test), and typically it works fine. But, like I say periodically it just stops and throws the above error, a simple IISReset fixes it but obviously I can't do that every half an hour, and it also drops the connections to the softphones.

    I've tried calling a new connection to the PBXConnection on session start, but still no joy, am I missing something, where would be best to look, from what I can see the logs don't really offer any additional info other than there's no connection to the config server.

    Any help would be appreciated...
     
  2. edossantos

    edossantos Support Team
    Staff Member 3CX Support

    Joined:
    Jun 27, 2007
    Messages:
    1,080
    Likes Received:
    77
    Hi there!

    Are you specifying a unique "ApplicationName"? Did you check the 3CX logs from "C:\ProgramData\3CX\Instance1\Data\Logs"? Maybe there you have some explanation about why the connection is rejected.

    Regards.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.