Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Configure 3CX to use Public address in the SIP header

Discussion in '3CX Phone System - General' started by teddylai, Apr 29, 2010.

Thread Status:
Not open for further replies.
  1. teddylai

    Joined:
    Apr 29, 2010
    Messages:
    1
    Likes Received:
    0
    Everything is working fine after I installed the 3CX server. However after several days of working, we have problem that intermittently we are not able to make outgoing call. I only have problem with mynetfone SIP trunck. Mynetphone SIP trunck authenticate by the public IP address. No registration is required. However, I can make outgoing call with other VOIP provider which requires registration.

    I then turn off SIP ALG in our router (NETGEAR DGN2000) as I read some article that this may cause problem. I cannot make any outgoing call from Mynetfone after turnning it off. The INVITE request is rejected by Mynetfone as the INVITE message is using our internal IP address.

    I suspect the ALG is not working correctly in the Router and that is why it is failing intermittent. I would like to turn it off.

    Is there any way I can configure the 3CX to use the public address in the SIP header? If so, it may solve my problem.



    Thanks
    Teddy
     
  2. pcunite

    Joined:
    Apr 12, 2010
    Messages:
    29
    Likes Received:
    0
    Verify how long your router/firewall keeps UDP ports open and set a keep alive interval to a value less than that.
     
Thread Status:
Not open for further replies.