Configure 3cx to work with Sipgate.co.uk

Discussion in '3CX Phone System - General' started by Anonymous, Nov 30, 2006.

  1. Anonymous

    Anonymous Guest

    Can anyone tell me how to configure to work with sipgate so that it registers and routes inbound call to an extension. I have experimentated with many different settings. I am using a Cisco router and have tried with SIP switched on and off in the firewall

    Log included below

    14:59:27.654 Registrar::eek:nRefresh: Refresh: sip:100@10.1.2.3:3706
    14:59:27.654 AuthMgr::eek:nAuthSuccess: Extension "3CX Phone"<sip:100@data>;tag=13196 has been registered successfully
    14:44:32.185 Registrar::eek:nRefresh: Refresh: sip:100@10.1.2.3:3706
    14:44:32.185 AuthMgr::eek:nAuthSuccess: Extension "3CX Phone"<sip:100@data>;tag=16498 has been registered successfully
    14:33:45.716 Terminated c21 "3CX Phone"<sip:100@data> <sip:08450044880@data> Call ended
    14:33:38.294 Calling c21 "3CX Phone"<sip:100@data> <sip:08450044880@data> Send INVITE to [#1047267 @Sipgate]
    14:33:38.154 Routed c21 "3CX Phone"<sip:100@data> <sip:08450044880@data> From: Ext:100; To: [#1047267 @Sipgate]
    14:33:38.154 CallConf::findDestination: Found destination [#1047267 @Sipgate] for caller Ext:100
    14:33:38.107 Registrar::checkAor: Registrar resolved sip:100@data as <sip:100@10.1.2.3:3706>
    14:33:38.076 Incoming c21 "3CX Phone"<sip:100@data> <sip:08450044880@data> Incoming call from 100
    14:33:38.076 AuthMgr::eek:nAuthSuccess: Extension "3CX Phone"<sip:100@data>;tag=17123 has been registered successfully
    14:32:55.544 Terminated c20 "3CX Phone"<sip:100@data> <sip:08450044880@data> Call ended
    14:32:36.544 Calling c20 "3CX Phone"<sip:100@data> <sip:08450044880@data> Send INVITE to [#1047267 @Sipgate]
    14:32:36.326 Routed c20 "3CX Phone"<sip:100@data> <sip:08450044880@data> From: Ext:100; To: [#1047267 @Sipgate]
    14:32:36.326 CallConf::findDestination: Found destination [#1047267 @Sipgate] for caller Ext:100
    14:32:36.263 Registrar::checkAor: Registrar resolved sip:100@data as <sip:100@10.1.2.3:3706>
    14:32:36.247 Incoming c20 "3CX Phone"<sip:100@data> <sip:08450044880@data> Incoming call from 100
    14:32:36.247 AuthMgr::eek:nAuthSuccess: Extension "3CX Phone"<sip:100@data>;tag=19798 has been registered successfully
    14:32:04.779 Terminated c19 "3CX Phone"<sip:100@data> <sip:08450044880@data> Call ended
    14:31:44.326 Calling c19 "3CX Phone"<sip:100@data> <sip:08450044880@data> Send INVITE to [#1047267 @Sipgate]
    14:31:44.201 Routed c19 "3CX Phone"<sip:100@data> <sip:08450044880@data> From: Ext:100; To: [#1047267 @Sipgate]
     
  2. Nick Galea

    Nick Galea Site Admin

    Joined:
    Jun 6, 2006
    Messages:
    1,718
    Likes Received:
    40
    Routing a call

    Hi,

    have you followed the procedures in the manual for setting up SIP gate with 3CX? And for routing an inbound call? If yes, at what point exactly are you experiencing problems.
     
  3. archie

    archie Well-Known Member
    3CX Staff

    Joined:
    Aug 18, 2006
    Messages:
    1,309
    Likes Received:
    0
    Hi,

    As far as I can see from the piece of log, our STUN client hasn't been able to resolve your external IP that is necessary to be known to be registered on VoIP provider. It may mean that either you've disabled mapping of port 5060 on your external firewall/NAT, or you have NAT translation that is not supported by 3CX Phone System. You should try to set at least ports 5060 (SIP) and 3478 (STUN) to be allowed to pass thru your external firewall/NAT.

    Best regards,
     

Share This Page