Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Configuring with Les.net

Discussion in '3CX Phone System - General' started by jlee, Feb 5, 2009.

Thread Status:
Not open for further replies.
  1. jlee

    Joined:
    Feb 5, 2009
    Messages:
    1
    Likes Received:
    0
    I'm trying to configure my new install of 3CX Phone System with my VOIP provider Les.net. However this is proving quite difficult. I have configured several other devices with Les.net with ease however this is my first windows based PBX.

    Does anyone have 3CX working with Les.net and could provide some in site into how I can get this configured?

    Thanks,

    Jason
     
  2. variatech

    Joined:
    Aug 7, 2009
    Messages:
    5
    Likes Received:
    0
    I'm having difficulty configuring with les.net as well. Anyone have suggestions?
     
  3. variatech

    Joined:
    Aug 7, 2009
    Messages:
    5
    Likes Received:
    0
    Jason,

    I was able to finally set up les.net to work with incomming lines. Go to VOIP Providers, edit provider les.net, click on the Source ID tab, check Source identification by DID box near the bottom, click the Add DID button, and add all the DID's associated with your les.net peer which is pointed to your 3CX box.

    I am still having issues with outgoing calls, however. No matter what I try, I still get the following error when trying to make an outbound call: [CM503003]: Call(30): Call to sip:18005551234@did.voip.les.net:5060 has failed; Cause: 408 Request Timeout; internal

    Does anyone have any ideas as to what I'm missing here?

    Thanks,
    Bryan
     
  4. variatech

    Joined:
    Aug 7, 2009
    Messages:
    5
    Likes Received:
    0
    OK, like I mentioned above, the incoming issues have been resolved. However, I'm still stuck on outgoing. Here's my error when placing a call:


    22:28:48.611 [CM503008]: Call(7): Call is terminated

    22:28:48.551 [CM503015]: Call(7): Attempt to reach <sip:18883527140@192.168.88.202> failed. Reason: No Answer

    22:28:48.551 [CM503003]: Call(7): Call to sip:8883527140@did.voip.net:5060 has failed; Cause: 408 Request Timeout; internal

    22:28:16.405 [CM503024]: Call(7): Calling VoIPline:8883527140@(Ln.10000@les.net)@[Dev:sip:1873735692@did.voip.net:5060]

    22:28:16.335 [CM503004]: Call(7): Route 1: VoIPline:8883527140@(Ln.10000@les.net)@[Dev:sip:1873735692@did.voip.net:5060]

    22:28:16.275 [CM503010]: Making route(s) to <sip:18883527140@192.168.88.202>

    22:28:16.275 [CM505001]: Ext.401: Device info: Device Identified: [Man: Linksys;Mod: SPA Series;Rev: General] Capabilities:[reinvite, no-replaces, able-no-sdp, recvonly] UserAgent: [Linksys/SPA942-6.1.5(a)] Transport: [sip:192.168.88.202:5060]

    22:28:16.205 [CM503001]: Call(7): Incoming call from Ext.401 to <sip:18883527140@192.168.88.202>


    Hopefully someone has a suggestion on something else to try. I'm sure it is something small like what I was missing on the incoming calls, but I can't seem to find it. I'm determined to get this to work, but am out of ideas. Yes, I know les.net is not a supported VOIP provider, but I have many other devices using them, and I like 3CX so much, that I hate to switch.

    Thanks for any suggestions.

    Bryan
     
  5. tpinnovations

    tpinnovations Member

    Joined:
    Jul 30, 2009
    Messages:
    296
    Likes Received:
    0
    What do you have for your outgoing proxy?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. variatech

    Joined:
    Aug 7, 2009
    Messages:
    5
    Likes Received:
    0
    Hi there,

    Thanks for your reply.

    I did have the wrong info in my previous log above, but I kept changing things trying to get it to work, I forgot to change it back before posting that log. It should be did.voip.les.net. I changed it now and here is the new log:


    21:46:18.071 [CM503008]: Call(5): Call is terminated

    21:46:18.051 [CM503015]: Call(5): Attempt to reach "Houston,TX"<sip:18883527140@192.168.88.202> failed. Reason: No Answer

    21:46:18.051 [CM503003]: Call(5): Call to sip:8883527140@did.voip.les.net:5060 has failed; Cause: 408 Request Timeout; internal

    21:45:45.834 [CM503004]: Call(5): Route 1: VoIPline:8883527140@(Ln.10000@les.net)@[Dev:sip:1873735692@did.voip.les.net:5060]



    It looks like pretty much the same error. Do you have another idea on what to try.

    Thanks again,
    Bryan
     
  7. variatech

    Joined:
    Aug 7, 2009
    Messages:
    5
    Likes Received:
    0
    I just noticed something else this evening. When attempting to place a call on one of my extensions: If I go to the port/trunk status page while the outbound call is in progress, it shows registered (idle) the entire time. It seems like my outbound call is not triggering my trunk to go in to action.

    On inbound calls, as soon as the extension rings, the trunk status says dialing.

    My outbound rule is set to send outbound calls from this extension through that trunk, but maybe I'm missing a setting somewhere else?

    Thanks,
    Bryan
     
  8. tpinnovations

    tpinnovations Member

    Joined:
    Jul 30, 2009
    Messages:
    296
    Likes Received:
    0
    Check your outbound dial plan.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.