Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

"ContactUri" usually, content of Contact field

Discussion in '3CX Phone System - General' started by Andy Schmidt, Apr 28, 2008.

Thread Status:
Not open for further replies.
  1. Andy Schmidt

    Andy Schmidt New Member

    Joined:
    Apr 3, 2008
    Messages:
    118
    Likes Received:
    0
    Hi,

    when configuring a generic trunk, one of the "outbound parameter" options is the "Contact: Host" part.

    The DEFAULT value for the pull down is:

    "ContactUri" usually, content of Contact field

    When I place a call through that trunk, the provider receives the following contact header:

    Contact: <sip:myauthid@0.0.0.0>

    So, why is the "ContactUri" = 0.0.0.0? Where is that "Contact field" where it's taking that "0.0.0.0" from?

    When I change the drop down to OutHostPort - THEN it includes the correct external IP address of my 3CX server.

    (PS: The VOIP provider said it should NOT be 0.0.0.0: "This means that your system will never receive non-reply messages back from our proxy (such as BYE, or additional progress indication). This should be a valid IP address coming from your system.")
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. Andy Schmidt

    Andy Schmidt New Member

    Joined:
    Apr 3, 2008
    Messages:
    118
    Likes Received:
    0
    Hi,

    when configuring a generic trunk, one of the "outbound parameter" options is the "Contact: Host" part.

    The DEFAULT value for the pull down is:

    "ContactUri" usually, content of Contact field

    When I place a call through that trunk, the provider receives the following contact header:

    Contact: <sip:myauthid@0.0.0.0>

    So, why is the "ContactUri" = 0.0.0.0? Where is that "Contact field" where it's taking that "0.0.0.0" from?

    When I change the drop down to OutHostPort - THEN it includes the correct external IP address of my 3CX server.

    (PS: The VOIP provider said it should NOT be 0.0.0.0: "This means that your system will never receive non-reply messages back from our proxy (such as BYE, or additional progress indication). This should be a valid IP address coming from your system.")
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.