Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Corrupt voice mails for Operator extension

Discussion in '3CX Phone System - General' started by birmingham, Oct 8, 2013.

Thread Status:
Not open for further replies.
  1. birmingham

    Joined:
    Oct 17, 2011
    Messages:
    10
    Likes Received:
    0
    Things worked okay until a few weeks ago.

    But now, voice mails left after office hours are not retrievable for the Operator phone extension. That is, they appear in the 3CX client as new vmail, but when I try to play them either to speakers or the phone itself, I hear nothing. Same thing happens if I bypass the 3CX client, and use the telephone interface to dial 999 for voice mail. I've reset the phone and reprovisioned it ad infinitum. This issue does not seem to occur with other phone extensions.

    The only thing that I can think of that has changed is we backed up the 3CX software and moved it to another server with different ip address. I thought I made all the ip-related changes needed, but maybe I missed something. All other functions seem to be okay, so it might not be related to the software migration at all..

    This is a critical issue, we are missing our after hours voice messages!
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,113
    Likes Received:
    329
    That's a pretty significant change right there.

    I would confirm, in the phone settings, where they think that they are to register, and, check the 3CX logs to see if anything is getting through from them. Did you run the 3CX firewall checker from the new server? Were all necessary ports forwarded to the new IP?
     
  3. birmingham

    Joined:
    Oct 17, 2011
    Messages:
    10
    Likes Received:
    0
    I have confirmed the phone settings, run the firewall checker and looked at server logs.

    Note that it is only 1 phone and only the voice mail function and only after hours messages. So, if it's an issue with the server, it's something related only to that one phone. It must be something with the after hours settings, but so far I can't find it.
     
  4. birmingham

    Joined:
    Oct 17, 2011
    Messages:
    10
    Likes Received:
    0
    The problem seems to be resolved now but I will monitor it. I believe it was due to the Windows user profile. I completely uninstalled 3CX phone client (it doesn't uninstall smoothly and leaves shortcuts all over the place), then created a new Windows user profile and reinstalled the client. Hopefully it will be okay now.
     
Thread Status:
Not open for further replies.