Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Could not contact boot server

Discussion in '3CX Phone System - General' started by scythe000, Feb 19, 2014.

Thread Status:
Not open for further replies.
  1. scythe000

    Joined:
    Nov 8, 2011
    Messages:
    66
    Likes Received:
    0
    Recently upgraded server to v11, and OS from 2003 to 2008. Now, none of my phones will provision.

    I followed these instructions:
    https://www.3cx.com/sip-phones/dhcp-option-66/
    but when i browse to:
    http://172.16.252.5:5000/provisioning/
    I get a 403: forbidden error.

    Any ideas?
     
  2. ian.watts

    ian.watts Active Member

    Joined:
    Apr 8, 2011
    Messages:
    532
    Likes Received:
    1
    You cannot browse the folder content.

    Finish a provisioning profile URL with a configured handset's MAC address..
    http://<pbx ip>:5000/provisioning/BESTMACEVER.xml
    That should bring back the XML file the phone is set to fetch from your scope option.
    If that is not working.. check to find out why, then update your option to whatever makes sense.

    Getting a 403 is at least expected, so the web services are returning "something".. so not a firewall issue.
     
  3. scythe000

    Joined:
    Nov 8, 2011
    Messages:
    66
    Likes Received:
    0
    ok, so i tried:
    http://172.16.252.5:5000/provisioning/0004F215EB11.xml
    and got a 404. I looked inthe provisioning folder, and that file doesn't exist. I have a <mac>.cfg file and a <mac>-directory.xml file.
     
  4. scythe000

    Joined:
    Nov 8, 2011
    Messages:
    66
    Likes Received:
    0
    I tried that url with .cfg instead of .xml, guessing maybe that's a typo in your instructions, and that works.

    I opened the cfg file and see references to Polycom 500 and 501, but not 550. I tried changing the the 500 to 550, and the phone pulled down a config, but it says config 0x20 error. Same if I edit the 501 line.
     
  5. scythe000

    Joined:
    Nov 8, 2011
    Messages:
    66
    Likes Received:
    0
    Ok, more progress.

    To get my IP 430 to work:
    1. Find cfg file in C:\Documents and Settings\All Users\Application Data\3CX\Data\Http\Interface\provisioning called [macaddress].cfg. replace [macaddress] with the actual MAC ID of the phone.

    2. Edit it to point to the [MACADDRESS]-phone.cfg file instead of the phone1_32x.cfg file.

    To get my IP 550 to work,
    first I had to download a new upgrader: SoundPoint_IP_BootROM_4_4_0B_Upgrader_release_sig.
    I put the 2345-12500-001.bootrom.ld in the provisioning folder. This upgraded the bootrom.
    Then I downloaded the new firmware, Polycom_UC_Software_4_0_5_C_release_sig_split,
    and put the 2345-12500-001.sip.ld file in the provisioning folder. This updated the phone again. At least now, it would boot and stay up. Then I had to log into the phone's web page and manually enter the extension and server info.


    Sounds like 3CX isn't properly generating configs. I've tried deleting the extension and doing it from scratch, and that didn't help.
     
  6. scythe000

    Joined:
    Nov 8, 2011
    Messages:
    66
    Likes Received:
    0
    Does anybody know how to fix the config generation?
     
  7. scythe000

    Joined:
    Nov 8, 2011
    Messages:
    66
    Likes Received:
    0
    Bump for help?
     
Thread Status:
Not open for further replies.