Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

could not establish a connection to the 3cx phone system web api

Discussion in 'Windows' started by Enoch, Feb 26, 2016.

Thread Status:
Not open for further replies.
  1. Enoch

    Joined:
    Mar 5, 2015
    Messages:
    35
    Likes Received:
    0
    After spending 4 hours going from v12.5 to v14 (note to developers, please make upgrades easier). I am now trying to get my presence and switchboard function of the 3CXPhone for Windows.

    I have opened every port I can find to do with 3CX (80, 443,5000,5001, 5060, 5061, 5090, 5484, 9000-9500)

    3CX phone registers and is able to make calls to both internal (to other extensions) and external (to outside numbers) just fine.

    I have read other posts: could-not-establish-a-connection-43569.html

    Still have not been able to get this working. Any other suggestions?
     
  2. daktur

    daktur New Member

    Joined:
    Oct 15, 2015
    Messages:
    230
    Likes Received:
    8
    Enoch,

    You have to use a Workaround when using iis version:
    The following command line should be used in 3cx server machine on command prompt:

    netsh interface portproxy add v4tov4 listenport=5000 listenaddress=<serverip> connectport=80 connectaddress=<serverip>

    And do the same for port 5001 to port 443

    to check if config is ok use the command:

    netsh interface portproxy show all

    for reference use this link:
    http://woshub.com/port-forwarding-in-windows/

    Presence and webrtc show be fully funtional now.
     
  3. Enoch

    Joined:
    Mar 5, 2015
    Messages:
    35
    Likes Received:
    0

    That was exactly the solution I was looking for. Once the port forwarding was in place, the presence, switchboard and all other things started working instantly. Thanks @daktur
     
  4. ccomley

    Joined:
    Apr 6, 2011
    Messages:
    95
    Likes Received:
    4
    So this suggests that despite installing the new edition to listen on port 80 and 443, as documented, and despite updating the Windows client to the newest versoin to match, the latter is still polling the former on ports 5000 and 5001, and, so, getting no reply?

    Three services packs in to V.14 is this likely to be rectified any time soon?
     
  5. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,379
    Likes Received:
    84
    This is not a mistake in the 3CX software, it makes sense that you would have this issue if the HTTP/S ports change.

    The reason is that prior to the upgrade, the 3CXPhone apps are 'looking' at port 5000/5001 for both Presence and the Provisioning file. Once you upgrade the server, the listening port of the server changes to 80/443, so the clients do not have some automatic way of knowing of this change. Simply sending a new Welcome Email to the user(s) of the 3CXPhone apps should be enough so that the 3CXPhone apps update their config and start looking at the correct ports again.
     
  6. Enoch

    Joined:
    Mar 5, 2015
    Messages:
    35
    Likes Received:
    0
    @NickD_3CX actually prior to the post, the 3cx client was upgrade from 12 to 14 and once I started this problem, I had also sent myself a new welcome email so I would have the latest settings (problem still persisted). And in the end it was still a port forwarding issue.
     
Thread Status:
Not open for further replies.