CTI mode on windows client

Discussion in '3CX Phone System - General' started by jofer, Nov 15, 2017.

Thread Status:
Not open for further replies.
  1. jofer

    Joined:
    Dec 5, 2012
    Messages:
    62
    Likes Received:
    4
    Hi

    I have v15 3cx on windows all the updates loaded, yealink phones provisioned. sometimes the 3cx client for windows when in CTI mode cannot control the deskphone.

    What would the reason be for this?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. eddv123

    eddv123 Well-Known Member

    Joined:
    Aug 15, 2017
    Messages:
    1,248
    Likes Received:
    175
    Hi jofer,

    Similar cases have been covered several times in these forums before however the interesting thing about your issue is that you say "sometimes". In a lot of cases it is network related (VLAN's blocking between Data and Voice networks for example) however if you say that it does work at times it would not be this.

    That being said a network description would be good if you are doing anything out of the ordinary (phone and Softclient outside of the local LAN and flat network).

    Also please try checking the machine the Softphone is running on:

    * You are on a supported version (Windows 7, 8, 8.1 or 10)
    * You say all the updates but have you checked your .NET Framework as well (.Net 4.5.2).
    * No windows firewall or anti-virus on the local machine blocking.

    Also worth checking your Yealink phone is on the latest "supported" firmware for 3CX.
     
    #2 eddv123, Nov 15, 2017
    Last edited: Nov 15, 2017
  3. GBC_James

    Joined:
    Feb 3, 2017
    Messages:
    66
    Likes Received:
    7
    Hi
    When ever we have had this problem, the simple solution was add the ip address of the desk phone to the Proxy Exceptions list in the PC's internet options (Internet Options - Connections - LAN Settings - Exceptions)
    This has always solved the problem for us.
     
    eddv123 likes this.
Thread Status:
Not open for further replies.