CTI Mode strips + from international number format

Discussion in 'Windows' started by ckatterl, Nov 15, 2016.

Thread Status:
Not open for further replies.
  1. ckatterl

    Joined:
    Nov 15, 2016
    Messages:
    50
    Likes Received:
    6
    Hi all,

    when dialling for example +436648xxxxxx from 3CX Phone in Softphone mode, it's working properly.
    When i dial the same number (same format) from 3CX Phone in CTI-Mode, the + gets removed and it's not working.

    The log shows:
    15.11.2016 13:25:17 - [CM503010]: Call(C:114): Making route(s) from Extn:9998 to <sip:436648xxxxxx@10.y.y.y:5060>

    I know,I can override this by enabling "replace + by 00" on each client manually, but there must be a more elegant solution for this?

    BR, Christian
     
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,470
    Likes Received:
    283
    Hello there,

    That option in the 3cx client is there specifically for this reason, to replace the + with 00 as the IP phones do not know what the + is.
    You could also replicate this with an outbound rule but that depends how you call local numbers and what the outbound rules for that is. You do not want to have conflicts between those. for example the international numbers excluding the + are 10 digits long. You can create an outbound rule and use the Calls to numbers with a length of 10 prepend 00.
     
Thread Status:
Not open for further replies.