cti_template.xml CTI Username/Password

Discussion in 'Windows' started by TSchuelke, Aug 25, 2014.

Thread Status:
Not open for further replies.
  1. TSchuelke

    Joined:
    Jan 30, 2009
    Messages:
    3
    Likes Received:
    0
    I changed cti_template.xml so it doesn't contain the default admin:%%DESKPHONE_PASSWORD%% but a hardcoded username/password combination we use internally. Upon restarting 3CXPhone, I can see that it's still using admin:abcd though when watching the traffic with Wireshark. Why's that? Is there anything else to change or is the file not used at all?
    I changed C:\ProgramData\3CX\Data\Http\Interface\MyPhone\cti_template.xml.

    /e: in the log I see that the Client requests the file on startup:
    192.168.0.112 - - [25/Aug/2014:18:14:15 +0200] "GET /MyPhone/cti_template.xml HTTP/1.1" 200 25308
    And I also see that it contains the correct URLs, but the client is not using them.

    /e²: actually the client is using them, but not the first part about authentication. Which means the username cannot be changed from the default "admin" to something else, unless I find a different way to do this. Sigh, that's what templates are good for...
     
  2. pj3cx

    pj3cx Active Member

    Joined:
    Aug 1, 2013
    Messages:
    645
    Likes Received:
    1
    Hi there,
    You are correct it seems 3CXPhone will always use admin at the moment, our R&D departement is looking into this.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.