Custom DID field in SIP INVITE

Discussion in '3CX Phone System - General' started by jsbird, May 5, 2009.

Thread Status:
Not open for further replies.
  1. jsbird

    May 5, 2009
    Likes Received:

    I really will appreciate the support of the 3CX users out there. I think there is a simple answer to my question which I don't get:

    First, here is the LOG in question:

    INVITE sip:7557777@;rinstance=0ab91c6fadb6acd1 SIP/2.0
    Via: SIP/2.0/UDP;branch=z9hG4bK5ti6ceig4uvpdeaojahhi3kbk6
    Max-Forwards: 69
    Contact: <sip:;transport=udp;wlsscid=1ae4691c270666;appsessionid=app-1etnv1symb1bm>
    To: <sip:7408200-tj5iadj011nf0@;rinstance=0ab91c6fadb6acd1;transport=udp;useradd=;userport=5060>
    From: "Unknown"<sip:27824020657@>;tag=SDe3c7001-1312b5db
    Call-ID: SDe3c7001-6bd6cb1342e08d2324953ab7899de1de-gurpkk2
    CSeq: 1 INVITE
    Allow: INVITE
    Supported: replaces
    Content-Length: 0
    X-DID: 9415387840
    X-UUID: 295cfc330b7a491caf1f76431376a387

    The main SIP account at SIP provider (Inphonex) is say 7557777.

    I am able to buy a number of direct numbers to link to this one sip account (7557777). One of the DID numbers is mentioned in the log above US# "9415387840".

    How can I guide 3CX to look for the DID number in the X-DID field? I am not familiar with SIP coding/fields at all. As you can see the DID number is not shown in other fields apart from the X-DID at the end?

    I am familiar with the DID settings, the problem I think is with the SIP field configuration selection "SIP Field containing DID numbers:" in (VOIP Providers > Inphonex > DID). Which one of the drop-down items will have the value of the "X-DID" field? (Request Line URI: User Part, Contact: User Part, To: User Part, From: User Part? etc.). I have tried all - with no luck. Do I need to change/add the SIP field values in 'Inbound Parameters' (VOIP Providers > Inphonex > Inbound Parameters). to look for the "X-DID" which will then trace through to the "SIP Field comtaining DID numbers" selections?

Thread Status:
Not open for further replies.