Custom template Snom 7xx

Discussion in '3CX Phone System - General' started by nickloenders, Apr 10, 2018.

Thread Status:
Not open for further replies.
  1. nickloenders

    Joined:
    Oct 10, 2016
    Messages:
    34
    Likes Received:
    2
    Hi,

    I want to force all my SNOM phones using the attended transfer method and NOT the blind transfer.

    I know the xml code for this is <disable_blind_transfer perm="PERMISSIONFLAG">VALIDVALUE</disable_blind_transfer>

    But where do I add this in the template and is a custom template provisioned well?? (as it indicates RED in the phones tab)

    AND is the correct format: <disable_blind_transfer perm="PERMISSIONFLAG">on</disable_blind_transfer>

    ?
     
  2. eddv123

    eddv123 Active Member

    Joined:
    Aug 15, 2017
    Messages:
    995
    Likes Received:
    153
    Hi nickloenders,

    Why not instead in the Management Console of 3CX >> Extension >> Provisioning simply select this for your extensions: "Select transfer method used (Blind or Attended) when you press a DSS key"

    This would do a similar thing but without the need to write a custom template (it does depend however on how you want the behavior to work).
     
  3. nickloenders

    Joined:
    Oct 10, 2016
    Messages:
    34
    Likes Received:
    2
    Hi, because Snom is not supported to use this kind of method :(
     
  4. eddv123

    eddv123 Active Member

    Joined:
    Aug 15, 2017
    Messages:
    995
    Likes Received:
    153
    You are correct, I have done a little digging (as I am a Yealink man) and the settings does not appear for snoms - not good!

    Does the behavior with your custom template work or not - I see you are just saying that they appear red in the management console interface - this is by design and will appear like this as it is a custom template.
     
  5. nickloenders

    Joined:
    Oct 10, 2016
    Messages:
    34
    Likes Received:
    2
    well I changed the template as such:

    <timezoneParams param="time_timezone_snom">
    <!--The first entry is the selected entry in management console-->
    <option value="BEL+1" id="39" zone="1:00"> 1 Belgium (Brussels)</option>
    </timezoneParams>
    <disable_blind_transfer perm="PERMISSIONFLAG">on</disable_blind_transfer>
    <Codecspriorities>

    But if I look in the webinterface this setting is not changed :(

    is this <disable_blind_transfer......> in the wrong place??

    I also did a factory reset of the phone and apparently when I change eg the BLF button I cannot reprovision anymore as it is a 'red' phone now
    fubar
     
  6. Saqqara

    Saqqara Active Member

    Joined:
    Mar 12, 2014
    Messages:
    939
    Likes Received:
    149
    Try this

    Make the change in the phone gui, export the settings and open up the file in a text editor. This way you can search for the option and it should give you the required syntax of the command

    Add the command to the end of the custom template, before </functionkeys> (around line 3234).

    Reprovision your phones and see what happens
     
  7. nickloenders

    Joined:
    Oct 10, 2016
    Messages:
    34
    Likes Received:
    2
    Als ik een save to xml wil doen krijg ik:
    This page contains the following errors:
    error on line 2212 at column 21: xmlParseEntityRef: no name
    Below is a rendering of the page up to the first error.

     
  8. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    753
    Likes Received:
    38
    ????? :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    nickloenders likes this.
  9. nickloenders

    Joined:
    Oct 10, 2016
    Messages:
    34
    Likes Received:
    2
    If a do an export to XML in my SNOM interface I get:

    This page contains the following errors:
    error on line 2212 at column 21: xmlParseEntityRef: no name
    Below is a rendering of the page up to the first error.
     
  10. nickloenders

    Joined:
    Oct 10, 2016
    Messages:
    34
    Likes Received:
    2
    Ok, problem was in the contacts in 3CX.

    I now did an export and see:

    <disable_blind_transfer perm="">off</disable_blind_transfer>
    <disable_deflection perm="">off</disable_deflection>
    <transfer_dialing_on_transfer perm="">blind</transfer_dialing_on_transfer>
    <transfer_dialing_on_other perm="">blind</transfer_dialing_on_other>
     
Thread Status:
Not open for further replies.