Customizing Phone Provisioning for 3CXPhone

Discussion in '3CX Phone System - General' started by LVJ, Dec 14, 2012.

Thread Status:
Not open for further replies.
  1. LVJ

    LVJ

    Joined:
    Jun 21, 2012
    Messages:
    3
    Likes Received:
    0
    I’m having problems with phone provisioning with 3CXPhone. The problem is that when I’m using provisioning then the external IP is getting the same port number as local IP in “My location” and under “Use 3XC Tunnel” the Local IP is not getting the port number?
    If I change the <PBXSipPort>zzzz</PBXSipPort> then the change is also used for the external IP?
    This is the setting I want:
    Local IP: yy.yy.yy.yy:zzzz
    External IP: xx.xx.xx.xx
    Local IP of remote PXX: yy.yy.yy.yy:zzzz

    Thanks

    Lasse
     
  2. danhriscanu

    danhriscanu New Member

    Joined:
    Nov 29, 2011
    Messages:
    232
    Likes Received:
    0
    Hi,

    Can you be more specific on that? What version of 3cx are you using? What phones are trying to provision. What is the exact option that you are using when provisioning the phones?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. LVJ

    LVJ

    Joined:
    Jun 21, 2012
    Messages:
    3
    Likes Received:
    0
    Hi,

    I'm using v11 sp .3 and this is for the soft client
    [​IMG]
    As you can see then the I am out of the office - external IP is getting the port number and not Local IP ao remote PBX: and that is not working.
    If I change it and remove the port nr. on I am out of the office - external IP and add it to Local IP ao remote PBX:, then it works
     
  4. cfive

    cfive Member

    Joined:
    Aug 20, 2009
    Messages:
    284
    Likes Received:
    6
    For the out of office settings and using the tunnel, you don't need the port - just the external IP. In the tunnel section, you will need to specify the local (lan) ip and port of the 3cx PBX. The tunnel will look after the rest, so long as you have the tunnel port matching on both ends.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.