Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Date Time Settings on Cisco Phone

Discussion in '3CX Phone System - General' started by mohammedzain, Jun 11, 2015.

Thread Status:
Not open for further replies.
  1. mohammedzain

    Joined:
    Jun 11, 2015
    Messages:
    6
    Likes Received:
    0
    Hi,

    We have Cisco 7940/41/60/61/70/71 phones connected to 3CX. The problem we face is incorrect time on all the phones showing 27/02/09 as date. How can we fix this problem? Thank you in advance.
     
  2. Saqqara

    Saqqara Well-Known Member

    Joined:
    Mar 12, 2014
    Messages:
    1,255
    Likes Received:
    203
    Sounds to me, if the phones can not connect to the timer server configured within 3CX - firewall maybe blocking UDP Port 123

    Time Server is configured under Settings -> Phone Provisioning (default is pool.ntp.org)
     
  3. izybr

    Joined:
    Jun 4, 2015
    Messages:
    7
    Likes Received:
    0
    I don`t know whether you auto-provisioned your phones, if yes then it may be problem with templates, check time settings in templates. Also make sure NTP server is configured on your 3cx, and as Saqqara suggested make sure the port is open.
     
  4. mohammedzain

    Joined:
    Jun 11, 2015
    Messages:
    6
    Likes Received:
    0
    Hi,

    Everything seems to be working perfectly with other Brand phones like Grandstream. Like izybr & saqqara suggested, the NTP server configuration is fine with Port 123 open. Tried everything else like changing NTP servers etc. Cisco phones are having correct configuration of NTP, as configured on 3CX, but its not synching..........Any help would be appreciated. Thanx.
     
  5. LiscardGP

    Joined:
    Sep 29, 2011
    Messages:
    56
    Likes Received:
    0
    Hi

    I have been using these phones provisioned using 3CX and they display the correct time, and directories also appear ok.

    It may be the version of the cisco SIP firmware you are using? I think I am using 8.5.4.

    Hope that helps

    Good luck
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. mohammedzain

    Joined:
    Jun 11, 2015
    Messages:
    6
    Likes Received:
    0
    Thank You LiscardGP. I just upgraded the phones to 8.5.4 but I still face same problem.
    I noticed that I get an error message saying "error updating locale" . Anyone can help me fixing this issue?

    I found the following on time;

    Date display & NTP
    The phone appears to support NTP for setting the date and time, though it apparently ignores the settings unless it is able to download locale configuration files from the TFTP server. The locale files are part of Cisco CallManager, so the phone reports an "Error Updating Locale" at startup if you aren't using a CallManager SIP proxy.

    Fortunately the phone will set its clock based on the Date header returned as part of the SIP proxy's registration response (200 OK). Asterisk sends the Date header during registration, but some VOIP providers to not. Hopefully future firmware revisions will enable NTP when CallManager locale files are not available.

    In the meantime, some localizations are available at Cisco Online (CCO-login required).

    http://www.voip-info.org/wiki/view/Standalone+Cisco+7941/7961+without+a+local+PBX
     
  7. LiscardGP

    Joined:
    Sep 29, 2011
    Messages:
    56
    Likes Received:
    0
    Hi

    Before the 3CX provisioning templates for my Cisco phones became available, I used to use a very basic configuration file. Using that file I used to get the message "Error updating Local". However the date and time were correct as these are set using different commands in the configuration file.

    Therefore I don't think investigating this message will not solve your date and time issue.

    Hope that helps
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.