DDI Not Working

Discussion in '3CX Phone System - General' started by Thomas Park, Jul 31, 2017.

Thread Status:
Not open for further replies.
  1. Thomas Park

    Joined:
    Jul 31, 2017
    Messages:
    9
    Likes Received:
    1
    Hi Guys,

    I am having an issue with DDI's not matching with their incoming rules on the 3CX Server.

    The sip provider uses a username and password to authenticate and I can see a 'called: 03xxx....'. But the number never seams to match the DDI rules. I am guessing that 'LineNumber' needs changing but I'm not sure what.

    I can see the inbound number also located under To: <sip:[number]@sipip:port;id> is there a way to look for the number in this To section? If so how would I go about this?

    Kind Regards,
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    5,425
    Likes Received:
    352
    Hello @Thomas Park

    If your provider sends the number to the PBX in a specific format then you need to change your DID's to match the format the provider is using. Or use the * symbol to let the pbx know that you need it to match only the numbers after the *. For example if your DID is 004412345678 and the provider sends the number as 012345678 then you can change your DID to *12345678. This way the number will match regardless if the provider sends the number as 00441234678 or 012345678.
     
Thread Status:
Not open for further replies.