Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

DDI on 7.1 problem - Fixed

Discussion in '3CX Phone System - General' started by looops, Mar 4, 2009.

Thread Status:
Not open for further replies.
  1. looops

    Joined:
    Mar 4, 2009
    Messages:
    5
    Likes Received:
    0
    Hi all,
    To 3CX devs - great product, many thanks.

    But I have a problem with 7.1 beta and the version 7.0 before it. Previously on 6.x I've had no problems with DDI but when I upgrade following the documented procedure: backup - uninstall - install - restore; my DDIs do not work. The main number that's bound to the VoIP provider works ok but DDIs that are carried by that same provider do not.

    This is the successful main number that works:

    08:59:51.670 [CM503004]: Call(6): Calling: RingAll800:100Ext.100103Ext.103101Ext.101107Ext.107@[Dev:sip:100@192.168.3.23:5060, Dev:sip:103@192.168.3.118:5060, Dev:sip:101@192.168.3.70:5060]
    08:59:51.654 [CM503010]: Making route(s) to <sip:800@1.2.3.4:5060>
    08:59:51.654 [CM505003]: Provider:[Magrathea] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [MSSGW] Transport: [sip:1.2.3.4:5060]
    08:59:51.654 [CM503001]: Call(6): Incoming call from 077123123123@(Ln.10002@Magrathea) to <sip:800@1.2.3.4:5060>


    This is the one that fails:

    09:03:27.753 [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    INVITE sip:0207DDI DDI@92.237.111.50 SIP/2.0
    Via: SIP/2.0/UDP 213.166.5.130;branch=z9hG4bKc3c6.3bff0036.0
    Via: SIP/2.0/UDP 213.166.5.134:5060;branch=z9hG4bK49C4E221AD
    Max-Forwards: 14
    Record-Route: <sip:213.166.5.130;lr=on;ftag=237884C0-C1A>
    Contact: <sip:077123123123@213.166.5.134:5060>
    To: <sip:44207DDIDDIDDI@n.e164.org.uk>
    From: "0771231231236"<sip:0771231231236@213.166.5.134>;tag=237884C0-C1A
    Call-ID: DF9E76-7D211DE-9EE9D4B2-5B8D3061@213.166.5.134
    CSeq: 101 INVITE
    Expires: 180
    Min-SE: 1800
    Allow: INVITE, BYE, CANCEL, ACK
    Date: Wed, 04 Mar 2009 09:02:20 gmt
    Supported: 100rel, timer, resource-priority, replaces
    Timestamp: 1236157340
    User-Agent: MSSGW
    Allow-Events: telephone-event
    Content-Length: 0
    Remote-Party-ID: <sip:07123123123@213.166.5.134>;party=calling;screen=yes;privacy=off

    I've tried entering the DDI as either
    0207DDIDDIDDI
    44207DDIDDIDDI


    It's not just the one DDI, cant make any of them work.

    Any suggestions welcome.
    Thanks.

    Paul.

    Fixed it - there's an entry in Edit Port [VoiP provider main number] for Source Identification by DID
    Thanks anyway.

    Paul.
     
Thread Status:
Not open for further replies.