Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Debian 3CX - Change local FQDN

Discussion in '3CX Phone System - General' started by JST, Jan 9, 2017.

Thread Status:
Not open for further replies.
  1. JST

    JST New Member

    Joined:
    Jan 8, 2017
    Messages:
    107
    Likes Received:
    1
    Is there a way to change the local FQDN? Let's assume I can currently access my 3CX box on the local network using abc.domain.com and now I would like to move the admin access to def.domain.com.

    I have already added the new DNS changes and found a few entries under parameters using URLs. Do I just need to change those or is there also some network configuration on Debian to be done?

    Thank you!
     
  2. GiannosC_3CX

    GiannosC_3CX Guest

    Hi JST,

    To change the local FQDN you need to take a backup without FQDN and license configuration. Then you need to uninstall the 3CX Phone System from your server and reinstall it. When beginning a new installation the system asks you to specify your default network adapter, local IP or using an FQDN. On local FQDN option you can type the local FQND. The new local FQDN must be in the local DNS server zone records pointed to IP address of your server. In this case everything in the local network works with local FQDN (provisioning files and etc..).

    If you need completely change your FQDN with new FQDN, please following the below link to find more info about that case: http://www.3cx.com/docs/key-already-bound/
     
    #2 GiannosC_3CX, Jan 9, 2017
    Last edited by a moderator: Jan 9, 2017
  3. JST

    JST New Member

    Joined:
    Jan 8, 2017
    Messages:
    107
    Likes Received:
    1
    Wow! That is more work than I was expecting. I would suggest to simplify this in a future upgrade because it isn't exactly virtual environment friendly.

    Anyhow, thank you for the quick reply and workaround!
     
Thread Status:
Not open for further replies.