Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Debian 9 Dependencies

Discussion in '3CX Phone System - General' started by dndx, Feb 11, 2018.

Thread Status:
Not open for further replies.
  1. dndx

    Joined:
    Aug 30, 2017
    Messages:
    9
    Likes Received:
    0
    Hello, I've been running 3CX on Debian 9 for some time.

    According to the instructions on the website, I had to install a certain libcurl3 version (7.38.0-4+deb8u5). To prevent it from upgrading, I set it on "hold" with apt.
    I have been getting error messages from 3CX saying that the new 3cxpbx (15.5.6354.2 -> 15.5.8801.3) depends on (according to apt list) the recent version of libcurl3 in the repositories. Because the website regarding referring to Debian Stretch still states that it requires the old version, I did not just want to un-hold it.
    Is it safe to upgrade libcurl now or does it still require that old version as stated on the website?

    Please note that this is a (at that time, clean) Debian 9 installation with 3CX installed on top of it. The 3CX-Stretch ISO has not been available when I installed it, and I have had massive problems with the 3CX-Jessie ISO.

    Also, as a side-question, I am so confused about licensing. I have a Standard Perpetual (V15.5.0) SC4 license. I understand that after one year, I won't get updates anymore, but how? I mean, apt handles updates from the 3cx repository? The website now says that the annual Standard 4SC is free, but maintenance is 75€/y for perpetual? Consider me very, very confused, maybe someone can shed some light :)

    Here is the update log:
    Code:
    Reading package lists...
    Building dependency tree...
    Reading state information...
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
    3cxpbx : Depends: libcurl3 (>= 7.52.1) but 7.38.0-4+deb8u5 is to be installed
    libcurl3 : Depends: libssl1.0.0 (>= 1.0.1) but it is not going to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    Rollback to 15.5.6354.2...
    Reading package lists...
    Building dependency tree...
    Reading state information...
    3cxpbx is already the newest version (15.5.6354.2).
    0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
    
     
  2. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,222
    Likes Received:
    93
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. dndx

    Joined:
    Aug 30, 2017
    Messages:
    9
    Likes Received:
    0
    Okay thank you, that means I can safely upgrade libcurl3 to the current version. I will make a backup and then upgrade.

    I read a bit more about the license, am I correct that my Standard 4SC Perpetual License will be converted into a Standard 4SC Annual License permanently?
     
  4. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,222
    Likes Received:
    93
    If you have a paid 4 SC Std?, then nothing will happen.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. bravad

    Joined:
    Feb 17, 2016
    Messages:
    27
    Likes Received:
    21
    Hi StefanW,
    I pointed out that he has a bug with 3CX compilation Debian. Ticket ID: 180489 //
    internal ID of the case is # 20881

    https://downloads.3cx.com/downloads/debian9iso/debian-9.2.1-amd64-netinst-3cx.iso

    Research and Development don’t have eta.. Is it normal that you continue to offer to download a compilation that contains an error?

    Understand that I tell you this very respectfully. I would not want other people to experience the same troubles.
     
Thread Status:
Not open for further replies.