Debug information file not present

Discussion in 'CRM / Helpdesk / App Integration' started by linking13, Nov 17, 2014.

Thread Status:
Not open for further replies.
  1. linking13

    Joined:
    Nov 14, 2008
    Messages:
    42
    Likes Received:
    0
    I have a new project in wich the GUI selection list (debug information file) is empty. For other project on the same machine there are no problem, but for this project nothing is shown.

    I have checked the URL http://www.3cx.com/blog/docs/troubleshooting-vad-applications/ and this is the result:

    The project is compled and deployed in Debug mode

    The IVR called is the number of Debug mode Project

    3CXLogger.ini is correct
    [3CXIvrServer\Logger\Outputs\LogFile]
    MaxFileSizeKB=2048
    File=3CXIvrServer.log
    KeepBackup=1
    Format=$ShortDT|$ThreadID|$FileLine:
    Level=8
    Severity=Log Error Critical

    The file .DEBUGINFO is created

    All the ASPX, VXML and other related file are present
     
  2. VAD_Support

    VAD_Support Active Member

    Joined:
    Aug 6, 2009
    Messages:
    690
    Likes Received:
    0
    Hi there!

    If you open the DEBUGINFO file with a text editor, you will see something like this in the first line:
    START_CALLFLOW_EXECUTION: Main.flow - Build: 15

    That means that the output was created from build number 15.

    Then, if you open your VAD project file (YourProject.vadproj) with a text editor, you will see something like this:
    <DebugBuildNumber>15</DebugBuildNumber>

    If the build number of your project file is different from the build number in your debuginfo file, it will not be shown in the VAD window. That's because if versions are different, you may have a different flow in your designer than the flow really executed.

    This may happen if you build the project again in the VAD after deploying it. So, to avoid this issue, you need to:
    1) Make all your changes.
    2) SAVE all the changes to all the files and also to the Project (press the Save All button).
    3) Deploy your project in debug mode.
    4) Make the calls to generate the debuginfo files.
    5) Start debugging from the VAD.

    Pay special attention to not re-build in the VAD between deploy and debug, otherwise the debug files will not work.

    Kind regarsd.
     
Thread Status:
Not open for further replies.