Default audio location?

Discussion in '3CX Phone System - General' started by DeepB, Jan 26, 2018.

Thread Status:
Not open for further replies.
  1. DeepB

    Joined:
    Jan 4, 2018
    Messages:
    26
    Likes Received:
    0
    Hello,

    I have a few extensions without voicemail. When someone calls and they do not pick up I get the generic "Voicemail for this extension deactivated" (translated from German, not sure that is the equivalent wording in english).

    I would like to change that recording with a custom one.

    Can anyone tell me how to do that? Do I need to exchange the files? where are they located?

    thanks
    Daniel
     
  2. apostolis_3CX

    apostolis_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Nov 1, 2017
    Messages:
    149
    Likes Received:
    15
    Hello DeepB,

    Go in Settings >> System Prompts and click on Manage Prompt Set.
    Then select the prompt set you are currently using and click on Copy Prompt Set.
    Give a name to the new prompt set and click OK.
    Select the new prompt set as "Active Prompt Set" and again Click OK.
    Still on System Prompts Settings, in the search bar, search for VMLDSBL. This is the specific prompt that you want to change.
    Click on "Record By Phone" to record a new message(follow instructions).
    Restart the SIP Server Service for changes to take effect.
     
  3. DeepB

    Joined:
    Jan 4, 2018
    Messages:
    26
    Likes Received:
    0
    Where do I set the new promptset as active?
    prompts.PNG

    Is that correct?
    Because when I "play by phone" the VMLDSBL in this promptset I get the correct one. I restart sip-server. Unfortunately when I call a number without a voicemail I still get the default one.
     
  4. apostolis_3CX

    apostolis_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Nov 1, 2017
    Messages:
    149
    Likes Received:
    15
    Yes this is correct. Just by selecting the promptset and clicking ok it will be set as active. My mistake, I forgot to mention that you will also have to make one more change in the extension's options since the default promptset will be still active. To do so navigate to your extensions > select all (you can use the shift key) > edit > Voicemail > from the dropdown select your custom promptset and ok.

    No restart of the services is necessary at this point.

    Give it a try and let me know.
     
Thread Status:
Not open for further replies.