Delay when answering/dialing

Discussion in 'Windows' started by purpleone, Mar 29, 2012.

Thread Status:
Not open for further replies.
  1. purpleone

    Joined:
    Mar 18, 2009
    Messages:
    18
    Likes Received:
    0
    We have a setup of the latest Multi tenant, using Yealink T22 phones. The problem comes and goes where if someone calls in, the ring group dials all the handsets in the group, when someone pick up the phone there is a 4-5 second delay before the call is actually connected. Its not an audio delay, where the call is connected and it dead air for a few seconds. When you pick up the handset, the phones show is still ringing, then after 5 seconds you see the call timer start and you know the call has connected.
    The same happens dialling out. Pickup, dial the number and 5 seconds later the call starts to connect.

    This is a hosted system so all extension are 'external'. The handsets are setup to use the 3cx stun. There are no issues with audio. Everything works perfectly, apart from this delay.

    Anyone have any ideas what might cause the delay?
     
  2. albertc

    Joined:
    Nov 21, 2011
    Messages:
    89
    Likes Received:
    0
    It seem like there is/was some issue with the 3cx stun server the past few days. I have change mine to stun.counterpath.com and it resolved some of my issues. Give that a try first. Also, have you run the firewall checker where you have host your 3cx? Make sure all tests passed without any translation on all the ports that you use for that tenant.
     
  3. purpleone

    Joined:
    Mar 18, 2009
    Messages:
    18
    Likes Received:
    0
    Thanks for the reply, I'll try change the stun. Do need to change if on the handsets AND 3CX?
    I have run the firewall checker and all tests pass no problems.
     
Thread Status:
Not open for further replies.