Desktop components fail to install correctly on Windows 7

Discussion in '3CX Phone System - General' started by Copernicus, Feb 21, 2012.

Thread Status:
Not open for further replies.
  1. Copernicus

    Joined:
    Feb 21, 2012
    Messages:
    2
    Likes Received:
    0
    We were unable to correctly install the 3CX MyPhone Desktop components on a newly installed Win 7 computer where we previously used the Windows Easy Transfer tool (WET) to migrate data from an old computer. The “MyPhoneSilverlightCom.tlb” file in the "C:\ProgramData\3CXMyPhone Client Addin\" folder was empty because the registration of the COM objects failed. The MyPhone log file contained the following message: “Com object is missing”.

    The issue was resolved after importing the clean dcom.mig file using WET and rebooting the computer. You can create the migration file yourself from a "clean" Windows 7 computer, or download the file from the Microsoft TechNet article.

    This looks like a serious bug in Microsoft WET if you ask me, and has cost me many hours of troubleshooting. It was only after checking the "Component Services" control panel and seeing the red arrow on the "My Computer" icon that we finally had a hint of what was going on.
    If I didn't stumble on the following article I would never have guessed that WET was the culprit:
    http://social.technet.microsoft.com...l/thread/2f347a0d-f5e2-490c-8c82-c15864ce17c7
     
  2. FBW

    FBW New Member

    Joined:
    Nov 19, 2008
    Messages:
    108
    Likes Received:
    0
    Re: Desktop components fail to install correctly on Windows

    Hey, thanks for this very interesting feedback.
    Hopefully not too many people will stumble upon this situation but at least now we have a solution. ;)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.