Detect Version and Edition from inside 3CXPhone plugin

Discussion in 'Ideas' started by mcbsys, Feb 10, 2016.

  1. mcbsys

    mcbsys New Member

    Oct 8, 2008
    Likes Received:
    I've released a product based on a custom MyPhone CRM plugin. Since plugins currently require 3CX Pro Edition, I put that in my system requirements. The very first customer couldn't get my plugin to work. The plugins logs looked fine. Finally I walked him through checking his Edition in the dashboard. Oh, it's only Standard!

    Please provide methods within the 3CXPhone API to detect the 3CX Version and Edition. This will allow checking for compatibility as the plugin loads and logging or displaying an error.

    Also, please explain the assembly attribute CRMTargetEdition. The name and example indicate that you can set your plugin to target (work with) any edition of 3CX, but that does not seem to be the case.
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...