Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Dialing E164 formated phones in v15

Discussion in '3CX Phone System - General' started by jcasares, Aug 24, 2016.

Thread Status:
Not open for further replies.
  1. jcasares

    Joined:
    Dec 5, 2009
    Messages:
    92
    Likes Received:
    0
    After installing v15 I configured the sync with my Google Contacts in 3CX Phone. There (in Google Contacts) I have all the numbers formatted in E164 format.

    For my country (Argentina) that is:
    +54-11-4321-4321 (being country code, area code and phone)
    +54-911-9876-9876 (being country code, mobile area code and phone)

    NOTE: the dashes were added for explanation but are not there, only the plus sign.

    Trying to dial those phones doesn't work and in the logs I see these entries that don't give much info about the real issue:

    Code:
    08/24/2016 11:09:10 AM - [CM503014]: Call(C:87): No known route from Extn:208 to target: <sip:+5491198769876@127.0.0.1:5060>
    08/24/2016 11:09:10 AM - Call(C:87): from Extn:208 to +5491198769876 doesn't match any outbound rule. No outbound rule could be selected.
    08/24/2016 11:09:10 AM - [Flow] Target endpoint for +5491198769876  can not be built!
    08/24/2016 11:09:10 AM - [CM503010]: Call(C:87): Making route(s) from Extn:208 to <sip:+5491198769876@127.0.0.1:5060>
    08/24/2016 11:09:10 AM - [Flow] Refer: RefTo=<sip:+5491198769876@127.0.0.1:5060>; was call from="MakeCall" <sip:MakeCall@127.0.0.1:5060> to=<sip:*9208@127.0.0.1:5060>
    I do have the rules configured (see attached image) so I believe or something is not working properly or I'm missing some other configuration. Take in account the rules were added as a test, the final rules would be different to accommodate other countries.

    Any idea on this?
     

    Attached Files:

  2. Baguk

    Joined:
    Aug 5, 2016
    Messages:
    13
    Likes Received:
    0
    Hi!

    Short answer: If under "Settings" -> "E164" you have selected to process the numbers, you have selected your country code and area code, as well prefixes (probably 00 and 0) - than you have to define the prefix in the Outgoing rule just as "0911" - depending if you have selected to remove country code or not.

    Long answer: http://www.3cx.com/blog/voip-howto/call ... lert-info/
     
  3. jcasares

    Joined:
    Dec 5, 2009
    Messages:
    92
    Likes Received:
    0
    I already did two things:

    - Read that article but deemed not useful as it says that E164 processing is used for incoming calls.
    - Anyway, generated different rules to try in case that was applying to outgoing calls but none worked.

    Taking into account your comment I decided to get rid of E164 processing and maintained the outgoing rules I defined before and they work. So something is not correct in the E164 processing and it doesn't go to the logs so I'm unable to see it.

    In any case I don't really know if E164 processing was useful for us at all (I believe the SIP provider doesn't use it for incoming caller ID).

    Thanks you for the information!
     
Thread Status:
Not open for further replies.