DID not working, Outgoing Caller ID

Discussion in '3CX Phone System - General' started by SplendidCoffee, Dec 19, 2008.

Thread Status:
Not open for further replies.
  1. SplendidCoffee

    Joined:
    Dec 19, 2008
    Messages:
    4
    Likes Received:
    0
    Excuse my ignorance, I am a newbie...

    I have two issues:

    1) I've successfully purchased and setup a new 3CX v7 server with my account from NexVortex. I can make a receive calls just fine however when I add my additional DID numbers from NexVortex, they do not work. I've contacted NexVortex about the issue and they tell me the following:

    I've made this change to in the "Edit Provider" section of 3CX but this made no difference.

    2) My second issue is that being a small company, we have several people working double-duty. I have a DID for each department but would like outgoing calls to have different caller ids based on which department is doing the calling. For example, I have one person doing sales and accounting. If she is making a sales call I need her outbound caller id to be 269-555-1212. If she's making a call to a vendor I need her outbound caller id to be 269-555-1414. NexVortex says this is possible however it needs to be setup in 3CX. How do I go about that?

    Please help.
     
  2. SplendidCoffee

    Joined:
    Dec 19, 2008
    Messages:
    4
    Likes Received:
    0
    Sorry, my log info might be of some help:


    14:26:55.153 [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    INVITE sip:2695551212@[IPCENSORED] SIP/2.0
    Via: SIP/2.0/UDP 66.23.129.253:5060;branch=z9hG4bKa894.4c16a271.0
    Via: SIP/2.0/UDP 69.30.45.229:5061;branch=z9hG4bKeddb1b1f7bb8c1dc4cba8a7bb69c090a;rport=5061
    Max-Forwards: 16
    Record-Route: <sip:12695551212@66.23.129.253:5060;nat=yes;ftag=8c4c788e06de03693b1c8450dfb583d2;lr=on>
    Contact: "Anonymous"<sip:69.30.45.229:5061>
    To: <sip:12695551212@66.23.129.253>
    From: <sip:2695552020@69.30.45.229>;tag=8c4c788e06de03693b1c8450dfb583d2
    Call-ID: HOUMGC0320081219202458055482@209.244.63.37
    CSeq: 200 INVITE
    Expires: 300
    User-Agent: Sippy
    Content-Length: 0
    cisco-GUID: 691092698-270007612-1721669568-3565390115
    h323-conf-id: 691092698-270007612-1721669568-3565390115

    14:26:55.153 [CM302001]: Authorization system can not identify source of: SipReq: INVITE 2695551212@[IPCENSORED] tid=a894.4c16a271.0 cseq=INVITE contact=69.30.45.229:5061 / 200 from(wire)
     
  3. SplendidCoffee

    Joined:
    Dec 19, 2008
    Messages:
    4
    Likes Received:
    0
    No one can help me please?
     
  4. William400

    William400 Well-Known Member

    Joined:
    Aug 21, 2006
    Messages:
    1,005
    Likes Received:
    0
    HI

    In V7 please ensure that you have entered the DID in both required locations. The first is the DID tab in the provider settings. The other is the 'Source Identifcation by DID' field, also in the provider settings. That should solve your first issue.

    As to the 2nd issue the is not configurable to change based on the department they are using. If they have a SIP phone with multiple lines you can assign them a different extension per line, then set the 'outbound Caller ID' for each line. Based on the department they want to call out from they would dial out from the correct departmental line.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. NWTech

    Joined:
    Dec 10, 2008
    Messages:
    19
    Likes Received:
    0
    They only I can add and is a common mistake is the DID must include the country code. Make sure the 1 is in the DID in the VOIP provider main number and DID number. You can see from the logs the inbound number includes 1. I hope this helps.
     
Thread Status:
Not open for further replies.