different dhcp scope and trouble with Yealinks registering

Discussion in '3CX Phone System - General' started by engin411, Apr 8, 2015.

Thread Status:
Not open for further replies.
  1. engin411

    engin411 New Member

    Joined:
    Jul 3, 2009
    Messages:
    172
    Likes Received:
    0
    Having trouble with a new DHCP scope I setup in Windows Server 2012r2. Not sure if it's a 3CX issue or a Yealink issue. We have 25 T46G's with an occasional Cisco. My primary concern is the T46G's. Also posting this in the Yealink forum as I'm not sure what I should be chasing to get this working.

    Original workgroup network was 192.168.3.0/24. Recently changed to a domain with Server 2012r2 as DC/DHCP/DNS, on 10.1.1.0/8. At this point, the 3CX server remains at 192.168.3.200 as it was before the network change.

    DHCP for most devices works fine. However, the Yealink phones cannot register with 3CX when they have a 10.x address, even though the DHCP scope is handing out option 66 with the provisioning URL from 3CX. Seems they can't register when the 3CX server is using a 192. address and the phones are on the 10. scope.

    The box has a 2nd NIC, so I tried changing the internal IP used by 3CX to 10.1.1.6. So far, I have not gotten that to work.

    Then I tried making a 2nd DHCP scope to issue 192.168.3.x addresses just to the phones, with a policy in this scope listing the first 6 digits of the Yealink MAC of 001565 with a wildcard appended (*) - like this 001565*. But that doesn't work either.

    Any suggestions on how I can get the Yealinks to register with 3cx when they are using the new 10. addresses? Or another approach I'm not thinking about?
     
Thread Status:
Not open for further replies.