Different Incoming call behaviour in ver 10

Discussion in '3CX Phone System - General' started by leejor, Sep 5, 2011.

Thread Status:
Not open for further replies.
  1. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,368
    Likes Received:
    228
    I have one trunk on a gateway that is used only for outgoing calls from 3CX, but, is also connected to a fax machine, so all inbound calls are to be ignored by 3CX and ring the fax machine.

    In previous versions this worked just fine if, in the gateway settings, "Allow incoming calls on this line: was left unchecked. Now, with it unchecked callers get a recording from 3CX that the call is not authorized.

    14:34:51.828 [CM503019]: Call(96): Rejected! Line is 'Busy' because number of simultaneous calls per line XXXXXXXX05@(Ln.10005@XXX) is limited by Administrator

    I now have to check the box and be sure that the fax machine is set to answer before 3CX does anything else with the call.

    Should the option not allowing incoming calls not just tell 3CX to ignore the call as it did in the past?
     
  2. davidbenwell

    davidbenwell Active Member

    Joined:
    Apr 27, 2010
    Messages:
    704
    Likes Received:
    0
    have you tried setting "Require Registration for" Outgoing Calls in the PSTN Device list? and then reload the configuration back to the gateway?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,368
    Likes Received:
    228
    I configure the device(s) manually.

    The point of the post was that, without my changing anything, there is a different behaviour in the way incoming trunk calls are handled, now, even when the "Allow incoming calls" is not checked. I'm sure that there are other users that would like to use a fax line (one wired directly to a fax machine but shared with a gateway), for the occasional outgoing call (emergency PSTN backup/ 911 line?).

    In my mind, if that isn't selected, then all incoming calls should be ignored, not sent to a recording, as was the previous behaviour.

    I'm not certain that this began with the initial move to Version 10, it may have started recently after one of the updates. I do know that it did not work this way previously.
     
Thread Status:
Not open for further replies.