Digital recepcionist not receiving dtmf tones

Discussion in '3CX Phone System - General' started by Juan Marriott, Dec 29, 2017.

Thread Status:
Not open for further replies.
  1. Juan Marriott

    Joined:
    Oct 24, 2017
    Messages:
    20
    Likes Received:
    2
    A couple of weeks ago we started seeing erratic, random behaviur on IVR, repeats menu(like when detects invalid option), or transfer to a different extention that was dialed.
    Would be something wrong DTMF tones? inband/RFC2833
    3CX says its auto detected, trunk provider says its fixed at inband...

    Any ideas?
     
    #1 Juan Marriott, Dec 29, 2017
    Last edited: Dec 29, 2017
  2. eddv123

    eddv123 Active Member

    Joined:
    Aug 15, 2017
    Messages:
    904
    Likes Received:
    137
    First please try changing the trunk codec if a lower bit rate Codec has been chosen, then, in some cases, DTMF can have issues. For example if you change the list to G.711 U-law only on the trunk does this change anything ?

    What do you hear if you test a call via the IVR, is there any distortion as far as what you can hear ?

    If you run a wireshark capture, you will be able to see the DTMF digits being sent. It may be able to offer some useful information if you are familiar with wireshark.
     
  3. Juan Marriott

    Joined:
    Oct 24, 2017
    Messages:
    20
    Likes Received:
    2
    Changed codec to ulaw, no change. going to mount wireshark...
     
  4. eddv123

    eddv123 Active Member

    Joined:
    Aug 15, 2017
    Messages:
    904
    Likes Received:
    137
    Hi Juan,

    You will see the DTMF tones being passed hopefully a DTMF Event, you may also find this guide useful also: http://www.3cx.com/blog/voip-howto/dtmf-rfc2833/

    Are you using SIP trunks or a VoIP Gateway with your 3CX System ? I have known some VoIP Gateways to require some configuration to pass DTMF information.
     
  5. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,365
    Likes Received:
    227
    You will have to confirm the type of trunks used. From your statement, I'm assuming it is a PSTN gateway. If so, what make/model are you using. If Inband (Audio) DTMF is being sent, and no changes were made on the gateway itself (firmware), then it may be a "phone line" (noise/low level) issue. Perhaps affecting only one of the lines.
     
    eddv123 likes this.
Thread Status:
Not open for further replies.