Digital Recepcionist with no call audio

Discussion in '3CX Phone System - General' started by dlrmartin, Jul 26, 2007.

  1. dlrmartin

    Joined:
    Jul 26, 2007
    Messages:
    15
    Likes Received:
    0
    Hello,
    I'm really excited with this product, it's the best!

    But... I'm experiencing a trouble.
    I have all incoming calls working ok, but after setup a digital recepcionist:
    Call is attended by DR, tranfered to extension, but when extension pick up the phone no audio is transmited or received. I meant, PSTN caller and extension hasn't audio...
    Then, I remove DR and all works fine again...

    I'm confused, please help.
    Regards,
    Martin
     
  2. Costas3CX

    Costas3CX New Member

    Joined:
    Jan 23, 2007
    Messages:
    217
    Likes Received:
    0
    Hello Martin
    I would like some more info please
    The call is from PSTN line to DR , then you press option #? and transfer to extension , and then no audio?
    What is gateway model? what is phone model?
    When you phone from PSTN to extension directly, audio is ok?
    How about transfers. Do transfers work normally? Blind and attended work?
    Just some question that will help with troubleshooting...
     
  3. dlrmartin

    Joined:
    Jul 26, 2007
    Messages:
    15
    Likes Received:
    0
    Thanks for your answer.
    I'm using a gateway linksys SPA400, X-lite and eyebeam softphones.

    I've tested with all calls from PSTN.
    At DR I tested with following configs in diferent times:
    Key 0: connecto to extension
    Timeout : connecto to extension

    If PSTN line is routed to an extension or ring group, no problem.
    If PSTN line is routed to DR, the call is attended by DR and transfered to extension defined on DR, the extension rings and when person pick up no audio is listened by PSTN caller or extension person.
    When phone from PSTN to extension directly, audio is ok. Transfers are ok.

    Let me know if I could give you more information.
     
  4. dlrmartin

    Joined:
    Jul 26, 2007
    Messages:
    15
    Likes Received:
    0
    any updates?
    please
     
  5. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,821
    Likes Received:
    1
    It will be easier to investigate problems if you provide logs.

    Thanks,
    Stepan
     
  6. dlrmartin

    Joined:
    Jul 26, 2007
    Messages:
    15
    Likes Received:
    0
    hello,
    I just upgraded to build 2434
    And here I post logs generated when I make an incoming call answered by DR and tranfered to an extension, without audio. not audio at all.
    Please help me to find the trouble.
    I'm copying 2 tries with same result, no audio.
    192.168.7.1 is the server
    192.168.7.102 is the ext.
    192.168.7.12 is the gateway

    16:10:12.406 StratLink::eek:nHangUp [CM104001] Call(2): Ext.124 hung up call; cause: BYE; reason: SIP;description="User Hung Up"
    16:09:48.656 CallLegImpl::eek:nConnected [CM103001] Call(2): Created audio channel for Ext.124 (192.168.7.102:51880) with third party (192.168.7.1:7066)
    16:09:48.656 StratInOut::eek:nConnected [CM104005] Call(2): Setup completed for call from Ln:10010@spa400 to Ext.124
    16:09:45.500 CallConf::eek:nProvisional [CM103003] Call(2): Ext.124 is ringing
    16:09:34.015 CallLegImpl::eek:nConnected [CM103001] Call(2): Created audio channel for Ln:10010@spa400 (192.168.7.12:10000) with Media Server (192.168.7.1:7064)
    16:09:34.000 CallConf::eek:nIncoming [CM103002] Call(2): Incoming call from anonymous (Ln:10010@spa400) to sip:10010@192.168.7.12
    16:09:22.671 ServRegs::eek:nAdd [CM113002] Registered: Ext.124
    16:08:59.093 ServRegs::eek:nRemove [CM113003] Unregistered: Ext.124
    16:08:26.218 StratLink::eek:nHangUp [CM104001] Call(1): Ext.123 hung up call; cause: BYE; reason: SIP;description="User Hung Up"
    16:08:20.953 CallLegImpl::eek:nConnected [CM103001] Call(1): Created audio channel for Ext.123 (192.168.7.1:56512) with third party (192.168.7.1:7060)
    16:08:20.953 StratInOut::eek:nConnected [CM104005] Call(1): Setup completed for call from Ln:10010@spa400 to Ext.123
    16:08:08.390 CallConf::eek:nProvisional [CM103003] Call(1): Ext.123 is ringing
    16:07:57.062 CallLegImpl::eek:nConnected [CM103001] Call(1): Created audio channel for Ln:10010@spa400 (192.168.7.12:10000) with Media Server (192.168.7.1:7056)
    16:07:56.953 CallConf::eek:nIncoming [CM103002] Call(1): Incoming call from anonymous (Ln:10010@spa400) to sip:10010@192.168.7.12
     
  7. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,821
    Likes Received:
    1
    What is "Ext.124"?

    Thanks,
    Stepan
     
  8. dlrmartin

    Joined:
    Jul 26, 2007
    Messages:
    15
    Likes Received:
    0
    the extension 124 is where DR forward the call.
    So,
    if I call, DR pick up and offer to dial 0 to transfer to extension 124.
    when 124 pick up the phone, no audio in neither way.
     
  9. dlrmartin

    Joined:
    Jul 26, 2007
    Messages:
    15
    Likes Received:
    0
    any help. please?
     
  10. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,821
    Likes Received:
    1
    bind your gateway to Media server(spa400). Does it help?
     
  11. dlrmartin

    Joined:
    Jul 26, 2007
    Messages:
    15
    Likes Received:
    0
    Excellent SY!
    it works.
    Thank you.
    Martin
     
  12. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,821
    Likes Received:
    1
    I'm glad to hear it but please specify your gateway model.

    Thanks,
    Stepan
     
  13. dlrmartin

    Joined:
    Jul 26, 2007
    Messages:
    15
    Likes Received:
    0
    sure.
    I'm using linksys SPA400

    thanks
     
  14. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,821
    Likes Received:
    1
    I could be more smart if catch it two posts before! :oops: :lol:

    I need just kindly ask you to check how it works after binding on media server. Just pay attention on progressive delay during conversation or other audio artefacts

    Thanks,
    Stepan
     
  15. dlrmartin

    Joined:
    Jul 26, 2007
    Messages:
    15
    Likes Received:
    0
    hi,
    yes, we are experiencing long delays on communications...
    we are evaluating desactivate DR due to this trouble.
    do you have any fix?

    thanks
    Martin
     
  16. dlrmartin

    Joined:
    Jul 26, 2007
    Messages:
    15
    Likes Received:
    0
    Finally, due to hi delays we decided disble DR....
    Please found a solution to this issue
     

Share This Page