Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Digital Receptionist

Discussion in '3CX Phone System - General' started by wb9999, Jun 17, 2008.

Thread Status:
Not open for further replies.
  1. wb9999

    Joined:
    Jun 17, 2008
    Messages:
    6
    Likes Received:
    0
    Hi

    I am having a problem with 3CX.

    I have 7 extensions set-up, all at different sites. I can call each extension perfectly.
    I have 4 external VOIP lines. If I set-up a line to route to a specific extension, incomming calls work perfectly.

    If I set-up an incomming line to route to the digital reception, the relevant greeting plays. If the caller presses a number for a option the relevant extension rings. However, when the I pick up the extension I hear the greeting on the extension and the caller still hears the music on hold. This happens on all extensions - even an extension connected to the same router as the PBX PC.

    I have checked, double checked and triple checked the firewall. All extensions are on a VPN so route directly to the PBX PC IP.

    If anybody has any advice it would be greatly appeciated.

    Wayne
     
  2. wb9999

    Joined:
    Jun 17, 2008
    Messages:
    6
    Likes Received:
    0
    Matt,

    Answers below:
    Version of 3CX: 6 RC1 and 5.1 (tried both on different computers)
    Phones: Problem occurs with both Linksys SPA941 and an ATA with an analogue phone
    I am using just one 3CX server
     
  3. wb9999

    Joined:
    Jun 17, 2008
    Messages:
    6
    Likes Received:
    0
    That has no effect. Also, I have one extension set up to divert to an external mobile number if not answered after 30 seconds. The same thing happens with this - the caller still hears music on hold and the recipient hear the DR greeting.
     
  4. wb9999

    Joined:
    Jun 17, 2008
    Messages:
    6
    Likes Received:
    0
    Hi Matt

    All incomming calls are VOIP. No PSTN incoming.

    As a temporary measure I have installed 3CX on a PC at another site, and this works (although no sound when calls divert to voicemail, but that's another issue). I would prefer to move the 3CX server back to the original PC but it's not usable with the current problem I am experiencing. The routers at the 2 sites are identical with the same port forwarding settings so I can't workout why it works at one site and not the other.

    Wayne
     
  5. raldridge

    Joined:
    Jun 6, 2008
    Messages:
    21
    Likes Received:
    0
    I have this same issue - any solution?
     
  6. raldridge

    Joined:
    Jun 6, 2008
    Messages:
    21
    Likes Received:
    0
    Same issue for us with call queues - when you answer the call, the outside caller still hears the music and they never get connected to the inside phone.
     
  7. wb9999

    Joined:
    Jun 17, 2008
    Messages:
    6
    Likes Received:
    0
    I finally resolved the problem myself after 7 days...

    I uninstalled 3cx totally and installed from scratch (v6 final). Instead of restoring settings I set-up extensions, lines, groups and DR as new. It now works. For some reason, on 2 seperate machines, if I upgraded from a previous version I had the prolem.
     
  8. raldridge

    Joined:
    Jun 6, 2008
    Messages:
    21
    Likes Received:
    0
    That doesn't help me as I installed a fresh install of the release version 6. It is running on Windows 2008 though.
     
  9. raldridge

    Joined:
    Jun 6, 2008
    Messages:
    21
    Likes Received:
    0
    Thanks Matt, but for my testing, I am going directly to the queue. And if I test just going to the DR, the same problem occurs. I'm just testing one or the other right now and they both have the issue.
     
Thread Status:
Not open for further replies.