Direct SIP on multi-tenant Virtual PBX

Discussion in '3CX Phone System - General' started by njfrost, Feb 19, 2016.

Thread Status:
Not open for further replies.
  1. njfrost

    Joined:
    Aug 13, 2012
    Messages:
    22
    Likes Received:
    0
    Apparently Direct SIP is not possible on the v14 Virtual PBX in multi-tenant mode. (confirmed by tech support)
    I can find no mention of this change in any posts from 3CX.
    So is this by design? Or is it possible that the feature may reappear in the future?

    For me, this is a bit of a blow, as it will mean having to abandon my multi-tenant strategy; my IVR will be receiving calls via Direct SIP, from my client's customer service PBX.

    On a single instance installation, the Settings \ Network \ FQDN tab has a setting "Allow calls from/to external SIP URIs" and you can set the local SIP domain.

    Multi-tenant does not have this tab, and the setting is not available in the 3CX Virtual PBX Manager.
     
  2. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,255
    Likes Received:
    63
    Actually that is not quite true.... I just tested it myself and it works just fine, all you have to remember is to write sip port at the end of the URI e.g. instance01.mydomain.com:29060 (instance 25) as the Virtual PBX instances might not be listening on port 5060 which is assumed if you enter nothing.

    Also I had a look at a ticket that was opened today in the Support Department (not sure if that was you however) about Direct SIP and there was no mention of Virtual PBX and no 3CX Support Engineer confirmed such a thing in that ticket, the ticket was about Single-Instance installation only.

    Anyhow, it seems to work, so even though the "Allow calls from/to external SIP URIs" is not visible, it is there in the background and is enabled.
     
  3. njfrost

    Joined:
    Aug 13, 2012
    Messages:
    22
    Likes Received:
    0
    Thanks very much for the reply. That's great to know that it works, and how to do it. Panic over!
    I'll try it out.

    The reason I made that statement was the reply I got to my support ticket #12560
    "As Direct SIP Calls are not enabled by default, even on the standalone version, the lack of the check box limits the PBX to the default settings, which means direct SIP Calls are disabled."
     
  4. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,255
    Likes Received:
    63
    I'm glad we could help clear that up then :) :) :) :)
     
Thread Status:
Not open for further replies.