Disable Allow outbound calls on this line not working

Discussion in '3CX Phone System - General' started by edujim, May 20, 2013.

Thread Status:
Not open for further replies.
  1. edujim

    Joined:
    Apr 6, 2012
    Messages:
    19
    Likes Received:
    0
    What is the best way to Disable the use of a line for outbound calls on 3cx.

    I have a Grandstream GXW4108, on port 10007 I have unchecked the option, Allow outbound calls on this line. Doesn't seem to be working.

    I still want inbound calls to be processed on this line/port.

    Do i need to make a change on the actual Grandstream device? I was looking at option Port Scheduling Schema (Voip->PSTN)
    it is currently set at rr:1-8; wanted to change to rr:1-7;


    thanks
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,872
    Likes Received:
    304
    Re: Disable Allow outbound calls on this line

    Unchecking the option in the extension settings should work.

    You can also restrict outbound rules to extensions by adding the extensions allowed to use the rule. You can put in a range that excludes the extension you wish to exist. You can also create a duplicate rule, that will apply to only that extension. place it in the outbound rule list above the "general rule" that applies to all others. Rules are read from top to bottom so if a there is a digit match, that extension can be sent to something other than an outside call. If the set has an internal dialplan, that can be set-up to prevent outside calls from being dialled.
     
  3. edujim

    Joined:
    Apr 6, 2012
    Messages:
    19
    Likes Received:
    0
    leejor


    thanks for the reply.

    After i unchecked the option: Allow outbound calls on this line, i saved my settings and I generated config file. I rebooted the grandstream.

    VoIP phones are still using this port for outbound calls

    This there something that I should check on the grandstream gateway?

    I was looking at option Port Scheduling Schema (Voip->PSTN) on Grandstream webadmin > channels tab
    it is currently set at rr:1-8; wanted to change to rr:1-7; so it won't use that line.

    thanks again.
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,872
    Likes Received:
    304
    Sorry, i was thinking the you were trying to block outbound calls, out on the gateway, from one extension, and were using the "disallow" option in the extension settings. If you want to block calls on one trunk, on a gateway, (the last trunk?), then it may need to be done by downsizing the trunk group in 3CX. The single trunk would then have to be set-up as a new, one line trunk group.

    Some gateways address each trunk(PSTN line) by assigning a different port number to each, some make use of a prefix that is attached to the outbound number.
     
  5. trificsystems

    Joined:
    May 10, 2013
    Messages:
    11
    Likes Received:
    0
    Changing the port scheduling schema to rr:1-7 should work as it will exclude port 8 from the round robin. You can try prefixing the number in 3CX's outbound rules with 99 followed by the port on the 4108 you want the call to go to. So 992 will send the call to port 2 on the 4108
     
  6. jpillow

    jpillow Well-Known Member

    Joined:
    Jun 20, 2011
    Messages:
    1,342
    Likes Received:
    0
    Are you trying to block a call from an extension or for a particular port on the gateway.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. edujim

    Joined:
    Apr 6, 2012
    Messages:
    19
    Likes Received:
    0
    particular port on the gateway

    I'm trying to block outgoing calls from using that port.. inbound calls are allowed.

    Only option i think is go get a 1 or 2 port fxo gateway put that line on there and create an outbound rule that blocks

    i was thinking of getting a HT-503, or a patton 4112
     
  8. edujim

    Joined:
    Apr 6, 2012
    Messages:
    19
    Likes Received:
    0
    I will changing rr:1-7 tonight see if that works.. before i proceed


    thanks
     
  9. edujim

    Joined:
    Apr 6, 2012
    Messages:
    19
    Likes Received:
    0
    I tried changing the option Port Scheduling Schema (Voip->PSTN) to rr:1-7 but it automatically changes to rr:1-7;rr:8; after I reboot the gateway.


    Going to try the following which i found on the interwebs on an other forum for another pbx system no names will be used :)
    not sure if it will work but I'm willing to try.

    rr:1;rr:2;rr:3;rr:4;rr:5;rr:6;rr:7


    this is what the user wrote
    Round-Robin and/or Flexible: rr:1;rr:2;rr:3;rr:4;

    Note: This setting has no round-robin. Each line operates independently. If you want to address each trunk individually, you’ll want to use the above. If you want round robin to work, i.e. if one trunk is busy, the GXW will try another, use this instead:
     
  10. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,872
    Likes Received:
    304
    Probably because the config file is being downloaded from 3CX upon a reboot. You could try manually editing the config file, or edit the settings in the gateway, if possible, so that, after an initial download, it no longer downloads the original config each time it reboots. Then any changes that you make should remain.
     
  11. edujim

    Joined:
    Apr 6, 2012
    Messages:
    19
    Likes Received:
    0
    I totally overlooked that the Grandstream downloads the config from 3cx.. I will remvoe the Config Server Path and try again

    thanks!
     
Thread Status:
Not open for further replies.