Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Disable Autoanswer behavior for 3CXPhone client

Discussion in 'Ideas' started by Platonik, Jun 6, 2017.

Disable Autoanswer behavior for 3CXPhone client 5 5 1votes
5/5, 1 vote

  1. Platonik

    Joined:
    Dec 29, 2016
    Messages:
    9
    Likes Received:
    0
    We are currently testing the page functionality in a ring group that has extensions provisioned with a Windows 3CX client softphone and a Yealink T26P on the same extension. When making a page to this extension within the ring group the Yealink IP phone will not ring if the 3CX client takes the call first. We have to close the 3CX client softphone application and then the page will be able to activate the speakerphone on the Yealink (intercom).

    Currently, there is no way to disable the 3CX Windows client intercom auto-answer functionality.
     
  2. Platonik

    Joined:
    Dec 29, 2016
    Messages:
    9
    Likes Received:
    0
    Here was the reply from 3CX support:

    This is not an issue simply when you have two devices in a paging group and you page the group the fastest device will answer the paging first, in this case software is faster than hardware and will auto answer the paging (same will happen when you use two hardphones as well the fastest one will answer the paging first). The behavior is as expected however note that you can submit the "Disable Autoanswer behavior for 3CXPhone client" as a feature request at www.3cx.com/ideas for review by the appropriate department or use the 3CXPhone client in CTI mode so as not to answer paging calls (control a hardphone)