Disable IPV6 fully

Discussion in '3CX Phone System - General' started by datatech1, Nov 23, 2015.

Thread Status:
Not open for further replies.
  1. datatech1

    Joined:
    May 17, 2010
    Messages:
    11
    Likes Received:
    8
    Hi Guys,
    We had installed a new 3CX on Microsoft Windows Server 2012 R2, this was a Virtual Machine and the hot was also running Server 2012 R2.
    Integration components were installed and we had configured the network as per the installation instructions.

    The server has a public IP Address and there is no-nat being done on the server.
    The phones connect remotely from 2 public IP Addresses and they were all working fine except for the voicemail and IVR.

    Despite following the guide we had various problems with Voicemail and the Digital Receptionist (IVR) not working.
    Every time we tried to call the voicemail from a phone we received the following message:-
    This call could not be completed, please try again later. We apologise.

    We searched the forums and tried various options, we even tried removing the software several times and reinstalling it, we restored backups and eventually setup the system again from scratch but nothing worked, so this morning we lodged a support ticket with 3CX.

    We went through the usual checks to make sure all of the services were running and the IVR was also running.

    Eventually after a lot of head scratching we looked at the IP Address part, even though we had disabled IPV6 on the network card the system was still resolving pings to the Link Local Address which was causing the issues.

    To disable this we had to edit the registry on the 3CX Server.
    From RegEdit navigate to the following:-
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TCPIP6\Parameters
    On the right hand pane right click and add a new DWORD (32-bit) Value
    Call it DisabledComponents and make sure the value is ff in Hexadecimal or 255 in Decimal

    Restart your server and when it comes back up it should be working fine and your voicemail and IVR's should also be working.

    If it doesn't there is one additional step you will need to do, open IIS Manager and navigate to the instance01>>ivr and highlight it in the left hand menu.
    From the right hand pane you will need to double click IP Address and Domain Restrictions
    Then click the Add Allow Entry from the right hand menu (at the top of the screen) and add the Public IP Address of your 3CX Server in.
    After you have done this you will need to restart the web server, this should not drop any calls that are in progress, but it will kick you out of the web management portal if you were in it on your computer.

    I hope someone finds this useful as it took us a long time to get sorted as well as countless reinstallations of the system.

    Marc
     
  2. pj3cx

    pj3cx Active Member

    Joined:
    Aug 1, 2013
    Messages:
    646
    Likes Received:
    1
    Hi there,
    Thanks for the info, may I ask which version/service pack of 3cx phone system were you running?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. datatech1

    Joined:
    May 17, 2010
    Messages:
    11
    Likes Received:
    8
    Hi Pierre,
    We were using 3CX v14 Service Pack 1.

    Is this something you could integrate into the installer to add the registry key to disable IPV6 fully on the server?

    Marc
     
Thread Status:
Not open for further replies.