Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

DND Allowing Intercom Calls

Discussion in '3CX Phone System - General' started by DetroitRadiant, Dec 21, 2017.

Tags:
Thread Status:
Not open for further replies.
  1. DetroitRadiant

    Joined:
    Dec 21, 2017
    Messages:
    2
    Likes Received:
    0
    We have 3CX v. 15.5 and Yealink T-48G phones. The Yealink phones have a DND button, and when pressed, the DND icon shows on the phone and the presence indicators show a red square for Do Not Disturb. However, if you are on DND, someone can still intercom to your phone and it will come through instead of returning a busy indicator. I cannot figure out how to get it to block intercom calls as well.

    The 3CX system has dial codes that can be used. If we use those, the phones do not display the DND icon, but the presence indicator goes to a red square with a white line through it. This mode does NOT allow intercom calls to come through, however, it's not as convenient for people to use and they forget to take it off because the phone doesn't show any icon indicating they're in DND mode.

    Without having to use both methods every time someone goes to lunch, etc., does anyone know how to get the built in Yealink DND to block intercom calls, too?
     
  2. eddv123

    eddv123 Well-Known Member

    Joined:
    Aug 15, 2017
    Messages:
    1,427
    Likes Received:
    187
    Hi DetroitRadiant,

    I too have see different behavior on the desktop phone settings to the Client. Where I have not tested Intercom specifically (so cannot confirm if this is an isolated case) I can at least offer you some points to resolve this, I would look at either:

    * Disabling that DND button on the Yealink (this would be a custom template setting most likely) you would need to be familiar with the editing of configuration files.

    * Set up a custom Speed dial using the dial code for DND (default being *61 for ON *60 for OFF) and encourage people to use this instead.

    * Or even easier still I would disable the setting "Can intercom" under Extension >> Rights or Extension groups >> Group rights.

    This should give you enough to by-pass this issue.
     
    DetroitRadiant likes this.
  3. giwm

    giwm New Member

    Joined:
    Sep 27, 2016
    Messages:
    246
    Likes Received:
    42
    You also may find value in posting on Yealink's forums. Though, they've seemed to have hidden the forums a bit, and I'm not sure why. http://forum.yealink.com/forum/

    Usually take a fully day to get a response, but they're quite helpful.
     
    DetroitRadiant likes this.
  4. DetroitRadiant

    Joined:
    Dec 21, 2017
    Messages:
    2
    Likes Received:
    0
    I can't disable the intercoms because the system is configured specially so that internal calls to an extension go to an intercom and external calls ring. We do use the intercom feature, but we just don't want it coming through when someone is on DND because sometimes the front office doesn't check the presence indicators before sending a call.
     
  5. eddv123

    eddv123 Well-Known Member

    Joined:
    Aug 15, 2017
    Messages:
    1,427
    Likes Received:
    187
    I would look at my first two points then if disabling Intercom is not an option.
     
  6. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,400
    Likes Received:
    535
    Hello @DetroitRadiant

    This sounds strange. Let us investigate this issue and i will get back to you
     
Thread Status:
Not open for further replies.